HELP! Firmware update to WD Black 2 (Dual) to 01.01A02 causes extreme slowdown of disk I/O

I just installed my new WD Black 2 (Dual) drive on my Sony Viao Laptop running Windows 7 Pro x64.

There were some hiccups in the installation and disc cloning processes, but eventually, I got the drive up and running.

I used the laptop for a few days, and performance/speed of WD Black 2 (Dual) drive was great.

The firmware was  01.01A01.

Then, today, I upgraded firmware to  01.01A02 by following instructions provided by WD.

Message displayed stating that firmware upgrade was successful.

I restarted my system, and now the drive speed/performance runs so slow, it takes almost 10 minutes just to boot up.

Verry annoyed!!

I tried rebooting several times.

Tried running Data Lifeguard diagnostics.

Nothing helped.

Has anyone else experienced similar issue of disk I/O slowing down after firmware update?

Is it possible to downgrade firmware back to  01.01A01?

Does WD Support have any suggestions as to how to fix/solve this issue?

Below is a benchmark test of the SSD drive after performing firmware update to  01.01A02.


WD Black 2 Benchmark after upgrade firmware to 01.01A02.png

Hello and welcome to the community,

I recommend you contact support directly for assistance with this issue.

Contact WD

I have analysed the firmware update and AFAICT it targets the HDD but not the SSD.

Analysis of a Western Digital firmware update (for a different model):