HELP. 8TB G-tech USB 3.0 Drive Not Initializing

I have been an avid Gtech user since 2008, and have sworn by them to all of my colleagues. My first drive was a 4tb g-raid that lasted me almost 6 years. My second was a 2tb external g-drive that lasted about 8. I noticed some “signs” that my 2tb was about to go in the summer of 2020 and so I ordered a brand new 8TB external Gdrive from the WD website. Last friday I got the “Drive has been improperly ejected” message… ( Using 2018 version Mac Mini with Catalina ) . After that, the drive will not initialize… Disk utility doesn’t see it… the ports I plug it into dont show any device in system profiler ( I tried all of the ports, and I also tried it on my Imac and got the same results) . I tried a different USB cable… I haven’t backed this drive up in the last 7 months ( I know that is very careless on my part) . But it hasn’t been a top priority because the drive is less than 2 years old and I have never had issues with a Gdrive so “young”. The drive powers up, makes the initial noise like it’s about to mount, but then never does… and then just periodically makes a quick clicking sound that las about a second… Has anyone else experienced this and have any idea of A.) What the problem is… and B.) Solutions for data recovery other than having to send it out to a clean room. I opened a support ticket but only got one response so far asking for more info.

Hi @MEMedia,

Please contact the WD Technical Support team for best assistance and troubleshooting:
https://support-en.wd.com/app/ask