HDMI Audio Issue

I just bought a third WD Streamer for a friends new home theater. TV is a LG 42LK450, and the amp is a Sony STR-DH520. He also has a new Comcast HDMI cable box. The Sony has 4 HDMI 1.4 inputs, which the WD is plugged into. I have the WD audio configured for HDMI, and initially it all works as expected. The WD appears to communicate with the Sony, when I configure it on the WD, because the WD automatically picks up a list of the audio formats and displays them for approval. The problem crops up when we shut everything down, and then re-power everything. The WD now thinks that the Sony is PCM only, and we lose all audio other than stereo. No sound at all for Dolby or DTS movies. The only way to clear the problem, is to perform a HW reset on the Sony. Everything then works fine until the next power down. To get around this, I switched to a optical cable, and everything works. I really want to use the HDMI audio, because the optical interface is limited to 5.1, as far as I can tell. Sorry for the long message. What we may need, is a option for the WD to just “passthrough” the audio and disregard the automation that is going on.

… try doing MANUAL HDMI setup for Audio instead of Auto Detect.

I tried the manual setup several times, with the same results. I also turned off HDMI CEC, on the WD, Sony & LG. It just seems like the WD checks the HDMI audio format coming from the Sony at power on. For some reason, it senses that the Sony is PCM only. It may well be that the Sony is the issue, but it is more easily fixable in the WD.> * * *
TonyPh12345 wrote:

… try doing MANUAL HDMI setup for Audio instead of Auto Detect.

Hmm.  So what happens if you make sure the Sony is up and running before you turn up the WD?

TonyPh12345 wrote:

Hmm.  So what happens if you make sure the Sony is up and running before you turn up the WD?

The same thing happened. I turned the Sony on and waited for a couple of minutes before turning on the WD. I guess that what I would like to see is a “lock” option in the HDMI Audio manual setup. 

OK. It looks like this is totally a Sony issue. Message #33 of the following AVS Forum thread clearly describes this issue.

http://www.avsforum.com/avs-vb/showthread.php?p=20368076

hi,

In recivers HDMI menu, set audioout -> AMP, then in wd set audio output -> Digital Pass-Through via HDMI Only with Automatic option. after that wd tv live will recognize your amp’s supported sound formats and you will be able to hear sound…