HDMI and Fiber Audio


#1

Is there anyway to bypass audio output via HDMI? For some reason my box doesn’t seem to want to switch using my Onkyo receiver, which mind you it did fine for the LONGEST time. 


#2

I’m not sure what you mean, I connect the WDTV to the TV with HDMI and get the audio on my Onkyo receiver with optical output. Have you selected Stereo out in the audio/video settings instead of bitstream?


#3

billstpor wrote:

I’m not sure what you mean, I connect the WDTV to the TV with HDMI and get the audio on my Onkyo receiver with optical output. Have you selected Stereo out in the audio/video settings instead of bitstream?

that’s exactly how i have mine set up as my receiver does not support HDMI.

WDTV to TV with HDMI

WDTV to RECEIVER with TOSLINK.

works perfectly, great picture, DTS sounds (i select DIGITAL for sound on the WDTV)


#4

brucered wrote:

 

that’s exactly how i have mine set up as my receiver does not support HDMI.

 

WDTV to TV with HDMI

WDTV to RECEIVER with TOSLINK.

 

works perfectly, great picture, DTS sounds (i select DIGITAL for sound on the WDTV)

Finally purchased an HDMI and Optical cable and plan to hook it up the same, should be arriving tomorrow. :slight_smile:

Only niggling doubt is whether my old non-DTS receiver (DD5.1 only) will handle the audio streams.  If not, might need to spend some of my leftover Xmas money on a new receiver!!


#5

No I don’t think you can decode DTS in the WDTV and pass it as a 5.1 PCM stream, but then again you can also save the money and transcode DTS tracks to DD with Eac3to in a matter of minutes -I think you can do it in a single step on the original video file, without demuxing/remuxing the audio track.

http://www.videohelp.com/tools/eac3to


#6

Cheers for the info / link.  That could save me a fair bit of cash further down the line.  ;)

Finally got my HDMI cable (Mediabridge, $10) and Optical cable (Amazon Basics, $6.50).

HDMI is set up as ‘Auto’ (outputs 1080p, 60Hz). Manually enabled 12bit Deep Colour.  Audio set to Digital.  Everything is working fine!  :D  Tried out a 1080p Pixar clip and it looked stunning, first time we’ve seen Full HD on our plasma.

Looks like none of my files have DTS encoded audio streams, so audio is playing fine and we’re getting surround sound.  

We’ve decided to dump my old Pioneer DVD player (it’s an old UK model, as am I! lol).

There’s a space big enough for a PS3 now, hmmmm… :slight_smile: