HDDs via USB Hub not working

Latest firmware.

I have several 2tb WD Essentials external HDDs.

If I connect any one to my new WDTV Live Streaming Media Player they work fine.  If I connect more than one via my powered USB Hub I get nothing.  Indeed, the player locks up.  ‘Video’ is highlighted at the bottom, but I can’t get that to move left or right.  Even the ‘Off’ button doesn’t work unless I press and hold for c.5 seconds.

The light on the front of the WDTV flashes as if it’s building a library, but the ‘Compiling…’ message doesn’t appear at the top of the screen as it normally does.  Also, the lights on the back of the HDDs are on solid, rather than flashing when in use/being searched/loaded.

I know others have got USB Hubs working.  What am I doing wrong?  Any tips?

My USB Hub is this one:


Any help would be very welcome.


Steve W

Hi there, can you post the model number of the Element drives? And are other USB drives working with that hub?

Thanks for the reply Pizza - I have it working now.

The problem (I think) was that I’d plugged in HDD 1 and the media library had stored on there, then I unplugged that and plugged in HDD 2, and that got its own media library, and so on.

When I then came to plug them all in they effectively had competing libraries.

I got it working by turning the library off, and plugging in each HDD one at a time and deleting the libraries so that none remained.  I then did a full power down reset of the player, plugged all the HDDs into the hub, the hub back into the player and tirned it all on again.

Worked first time…erm…second time.  I had one folder containing a film and metadata, etc, on two of the drives.  I think as these folders were identical it fowled things up a bit.  Deleted one of them and went through the process again and it worked very well.

Steve W

That’s good to know :slight_smile: