HD not showing up

I am sure this has been ask/explained somewhere he in the forums but I can’t see to find it.  My HD will not boot up to the computer. I can hear it spin up and it sounds like its reading, but it never shows up on the computer. Mac or PC.  Its not making the clicking sound that they do when they have gone bad. The only other indicator I have is the LED is constantly flashing. 

Also, this isn’t a new HD. I have been using it for a long time and this just started. 

Is it a powered or USB powered drive? I just may be the cable.


@Joe S or Mhowie: 

Have you found any solutions to this problem yet? I am having the same issues, and no matter what I do, it won’t recognize under My Computer. As you’ve said, it shows everything is fine in Device Manager, I have uninstalled and reinstalled all drivers and SES…no change, only flashing LED. Mine is the My Book Essentials that has a power cord and a separate USB cable.

I called tech support and the guy seems to think its the USB cord for some reason… I’m doubtful that is the problem but we’ll see. I also discovered that it doesn’t seem like it’s being assigned a “drive letter” in Device Manager. I tried to add one, but then it gives me an “I/O” error, or tells me that the drive needs to be formatted first, which can’t happen because…

I have all of my family photos from the last 10 years on this thing! The My Book worked perfectly fine out of the box, and out of nowhere I started having this problem. I HAVE to recover those photo files! It just makes no sense that it was working perfectly well one moment and not working at all the next, just in enough time to move my most important files onto it!