Having trouble safely ejecting 1TB Passport drive

I have had this problem since getting the drive a few weeks ago. Sometimes it can be “safely removed/ejected” from either the Windows 7 option or from SmartWare, but mostly it keeps telling me the drive is being used. I shut down all programs/applications I was using (task manager shows nothing running), but the drive still will not shut down. It will show a steady light, and when I try to safely eject it - the lights start blinking rapidly.

Another post suggested logging off and back on - doesn’t work for me. I have left it in place for hours, thinking it just needed to stop whatever process was occurring, but still won’t safely eject. When I try shutting down my laptop and removing the Passport, then I can’t access the files using my desktop.

I am not using SmartWare at all, just copying photos from main computer to the drive. Using the drive on both an Aesus laptop (Windows 7) and Dell desktop (Windows XP). 

Any ideas?


As a recommendation,

1- you may try to turn the computer off with the drive connected.

2- turn the drive back on and don’t open any programs on your computer.

3- try again to remove the drive to see if it does the same.

Also you may try installing a third party software to eject the drive to see if is a problem with the computers that you are using.

1 Like

It could be several things. AV software is one possibility. Do you use any type of automatic backup or sync software? Look in Device Manager and see if write caching is enabled. It’s in properties on the policy tab. does it happen on both systems?



I don’t see where the Policy tab is. I’ve checked for both the Passport drive & the laptop itself.

I do us an Anti Virus software - ESET Nod32, I’ll look around there & see if that is the problem. 

Thanks, Dms

Thanks, I have had the problem on both the desk-top & the laptop. For the laptop, shutting it down, restarting & then ejecting the drive worked. I haven’t tried it on the desktop yet. 

Not an ideal solution, but it works.

Thanks again!