Have I got a bad one - disk or utility

Dear Forum,

I have just bought a 2TB Ultra to use as a back up for a 2TB MyCloud.

I connected it up to my Mac OSX and used the bundled utility to reset the sleep time and run diagnostics.

I intend to leave the Ultra permenantly connected to the MyCloud so I reset the sleep time to 15mins.

When I ran the quick scan diagnotic it cancelled after about 80% - it did this 3 or 4 times.

I was begining to think this was an NTFS issue and that my OSX couldn’t write to the Ultra.

On the 5th attempt, the scan successfuly completed - so that’s that theory gone.

I have tried the full scan twice - again, it self cancels.

I tried to use the registration, I filled out all the fields but it wouldn’t register.

Red text warned me that essential fields were empty - but all fields were completed.

Now I am wondering have I got a bad disk or is it the utility app playing up.

Would the advice be return it (I only bought it yesterday) or reformat EXFAT and try again.

Thanks D


If you are planning to use this drive on a Mac then I recommend you format it for Mac.

How to partition and format a WD drive on Windows (8, 7, Vista, XP) and Mac OSX