Has 1.04.12 been pulled?

I just went to upgrade the firmware and it keeps timing out when checking for the update.  Internet access is fine since I can use Pandora fine.  Has the new version of the firmware been pulled or is it just  a server problem?

It wouldn’t be a bad idea, but I don’t think that’s the case. You can still download the firmware from here:


Is it not possible to do this with a USB flash drive?  I extracted the 4 files to the root of a USB flash drive as per the instructions but it never recognizes a firmware update on there when I plug it in or restart with it plugged in.

Are you sure you have the right hardware for it?

What version are you CURRENTLY running?  

Yes, I just got the SMP player from Amazon with the 1.03.10 firmware pre-installed.

This is getting very frustrating.  Is a flash drive supposed to work?  I have tried formatting it both FAT and FAT32 and it never detects the firmware update on there.

Go into SETUP / SYSTEM / AUTO DETECT NEW FIRMWARE and make sure it’s ON.

Auto Detect was on.  I just downloaded the firmware a second time and put it on a different flash drive and it detected the new firmware so maybe it just didn’t like something about that other flash drive.  Thanks.

Happened to me too. One time the files weren’t copied over correctly as I found out when checing the MD5s. Another time the stick just did not get detected so I used another one which worked fine.

I have a couple of flash drives and if there is a problem with one I use the other and then vice versa. There seems to be no reason why its recognised one minute and not another. I do reformat my drives before I add the files but I don’t know if this just has a placebo effect.

I can’t find 1.04.12 on that page …

R4RM3K wrote:

I can’t find 1.04.12 on that page …

Thats because another firmware update has replaced it. You can get it from here.