Harddrive Needs formatting? after 4 months of use, worst hard drive i've had

so as of some time this morning till now i have received 172 messages to format my drive before i use it. i have had this drive more then 5 months, and have lost 6 YEARS worth of family stuff, photo’s, music, documents, etc. I will no longer trust WD with anything as every drive me and my family has had has failed within 6 months of the first use after the first format. Now can someone tell me why this happened or how to get it so i can get another 2TB drive to put everything on?

What OS are you using and is it up to date? Does the drive show up in Disk Management and does it say anything there like Raw? Do you always remove the drive properly? Not doing so can cause corruption. Are you using this drive on mutiple PCs with different OSs?


so i can see it in, Device manager/Disk Drives, i set it to show empty drives, and 2 seconds later it disapeared and said i needed to format it to use it again for the 180th time, i’m on Windows 7 professional, i have never disconnected it, i start and turn off the computer with it plugged in, its a 2 TB external with a seperate power suply. the hard drive stopped in the middle of the night while i was watching movies plus i forgot to mention i was finishing a download. my friend downloaded the same file and had no problems

hi Joe, i’m having a very similar problem on a My Book 3.0 1 terabyte

partitioned into 687.37 gig & 244.14 gig

was using it for 9 months and just today, after not using it for like 2 weeks, noticed the drive not recognised, and after disk management, like you mentioned, it says the 2 partitions are now RAW

what is this RAW and how do i recover the partition information and my files?

i have the latest testdisk, partition magic 7.0 (rather old), 

none of them recognise this problem during the scanning.

i have recuva as well. and also “find and mount” software.

anyone, please help?  how do i get out of this RAW ?

want my files back … thanks!

It sounds like a corruption problem. Did you try EaseUS Data Recovery http://www.easeus.com/resource/repair-raw-disk.htm  It may be try and buy after you recover a set amount. Since none of the software seems to work there is something that might work I’ve seen it posted a few times. Basically you run the command prompt to convert FAT32 to NTFS. You need to run Command Prompt as an administrator here is a link  http://support.microsoft.com/kb/214579 the command is about half way down I would try this as a last resort.


1 Like

what’s the outcome?

re: my problem posted 2 posts ago (April 2012)

i found another clue as to what might be the problem

testdisks reports a strange geometry and says that geometry must be set right before Analyze can be successful.

my geometry is very unusual

model number:

WDBAAK0010HCH-00 1911B

this makes it the 1TB version I believe.

testdisk reports geometry as:

Drive J: - 738 GB / 687 GiB - WD My Book 3.0 1123

CHS 1441517568 1 1, sector size=512

cylinders 1441517568

heads 1

sectors 1

sector size 512

how do I find the correct geometry for this model of harddisk to key in manually into testdisk and re-Analyze again?


my harddisk had 2 partitions,
738 (687.37) Gb and 262.12 (244.14) GB in size.

the current results from testdisk is as follows:

Drive J: - 738 GB / 687 GiB - WD My Book 3.0 1123

it detected this first partition and called it Drive J: (738 GB / 687 GiB) but did not detect the second one.
the partition information is corrupted therefore it does not know that it is one partition, and missing another.

the CHS reading is as follows:

Drive J: - 738 GB / 687 GiB - CHS 1441517568 1 1, sector size=512

again, it only detects this first partition, and shows it incorrectly as 1,441,517,568 cylinders 1 head 1 sector.
in actual fact it should be something like 255 heads, 63 sectors right.
but now it reports 1 head 1 sector, and the cylinder reading 1441517568 x 512 sector size = 738 gigabytes. so the number is correct for this partition, but it’s displayed as 1 head 1 sector.

is this a common result from testdisk (1 head 1 sector) when it fails to detect proper partition information? does it assume 1 head 1 sector first, until it completes the “Analyze” and later tries to assign a more correct 255 head 63 sectors ?

most importantly, the reason i ask is this:
(1) should I run Analyze using this CHS 1441517568 1 1, sector size=512
(2) or should i change the geometry manually to CHS 89730.31858076564 (that’s 1441517568 divided by 255 and 63) and change heads to 255, sectors to 63, sector size remains at 512, then run Analyze?

i ask this because testdisk advises to have correct geometry before doing Analyze.

please advise? thanks!

i opened the casing and it says:

Western Digital Caviar Black, 64 mb cache, model: WD1001FAES-00W7A0

LBA: 1953525168

it does not say what is the CHS geometry. 

this LBA number can be divided by 63, leaving 31008336

but 31008336 can’t be divided nicely into 255 or 256 or 240. ends up with a decimal point behind. 

sector size seems to be 512 because 1953525168 x 512 = 1 terabyte, which is the HDD size.

what do you think is the Heads number for this unit?  255 ? 256 ? something else ?

what would the CHS number be, for me to input into testdisk, to do a proper Analyze?

(By the way, I tried to do Analyze without correcting the CHS number - it went through the whole disk and says no partition found. asked if I wanted to “A” add a partition or just hit “Enter”)