Hard drive showing as other device and not in disk management or file explorer

I can not access a new internal hard drive in my computer. I have tried several things but still stuck. I suspect it is some driver issue but not sure what next steps i can try. Details below…


  • I can see the hard drive in the bios
  • I can not see it in disk management (nor the file explorer)
  • I can see it under device management as an “other device.” i can not seem to update the driver (automatically)

physical checks:

  • I tried different ports, sata cables, and power connectors - all with known working combinations from the other HDs
  • I tried the HD in a different computer and it worked perfectly

i have tried:

  • updating the bios
  • reinstalling windows (3 times or so)
  • searching WD website for drivers or utilities
  • switched from IDE to AHCI and reinstalled windows

computer specs:

  • OS: Win 10
  • Motherboard - Gigabyte GA-H55M-S2H
  • Processor - Intel i3-330
  • SSD - boot/windows Corsair Force Series 3 CSSD-F90GB3-BK 2.5" 90GB SATA III Internal Solid State Drive (SSD)
  • Hard Drive 2 - storage Western Digital AV-GP WD5000AVDS
  • Hard Drive 3 - storage WD 2 TB AV-GP WD20EURX <<<<< HD Can not see

Hi kware, I have that same motherboard, so I’m going to try find a solution, just let me think!