Hard drive failure? Or something else? (WD Elements 2TB)

So I’m the type of guy who’s competent enough that I cringe when someone isn’t using keyboard shortcuts, but as soon as you open up Terminal or anything of the sort I’m useless.

My (fairly new) WD hard drive shows up in Disk Utility, but not finder. Disk Utility says it’s unmounted. When I run first aid on “WD Elements 2621 Media” (it says this is the external physical disk?) it says everything is fine, but when I run it on the tab that shows up underneath (it says this is the USB External Physical Volume), I get this dialogue -

First Aid process has failed. If possible back up the data on this volume. Click Done to continue.

Under “Show Details” I see this -

Repairing file system.

Volume is already unmounted.

Performing fsck_hfs -fy -x /dev/rdisk2s2

Checking Journaled HFS Plus volume.

Checking extents overflow file.

Checking catalog file.

Incorrect block count for file shutdown_time

(It should be 1 instead of 0)

Invalid sibling link

Rebuilding catalog B-tree.

The volume Dov’s Magic Hard Drive could not be repaired.

File system check exit code is 8.

Restoring the original state found as unmounted.

File system verify or repair failed.

Operation failed…

When I click “Mount” at the top of the window, nothing happens. I’ve checked that I don’t have a faulty cable, USB port, or USB-C converter.

When I click “Info” for the volume, I get this -

Volume name : Dov’s Magic Hard Drive

Volume type : Physical Volume

BSD device node : disk2s2

File system : Mac OS Extended (Journaled)

Connection : USB

Device tree path : IODeviceTree:/PCI0@0/RP05@1C,4/UPSB@0/DSB2@2/XHC2@0

Writable : No

Is case-sensitive : No

File system UUID : FE4B5DA1-304F-373E-AFEA-A9B76188618F

Volume capacity : 2,000,021,315,584

Owners enabled : No

Is encrypted : No

Can be verified : Yes

Can be repaired : Yes

Bootable : No

Journaled : No

Disk number : 2

Partition number : 2

Media name :

Media type : Generic

Ejectable : Yes

Solid state : No

S.M.A.R.T. status : Not Supported

Parent disks : disk2

Don’t know if that’s actually of any use, but there it is.

Basically, is there any chance that I can recover my data? Has the drive failed? I’m fairly certain that most of it is backed up on an old time machine backup, but I’d rather not take that risk - sorting through an entire computer’s worth of backup files might drive me insane.

Also wondering if this is related to the fact that I had this drive connected to a non-powered USB hub. Just learned that you’re not supposed to do that. :grimacing:

Thanks so much for any help you might be able to send my way!

Hi,

The diagnostic tools can fix minor errors on logical level. If the repairing process fails, you should recover the data from the drive.

You could refer to the following link: https://support-en.wd.com/app/answers/detail/a_id/18754