Half price

My MyBook Essential was on sale for half price, so I bought two. Then,

  1. My desktop couldn:t recognize either drive. Why? Who knows?

  2. So I tried with a laptop, and no problem. I already had a backup drive for the laptop, but I guess I can go to the extra trouble of copying over and switching hard disks with the desktop.

  3. Then, the software on the CD wouldn’t install, so I download from the website, and that does install. Why?

  4. But it installs in a foreign language! I didn’t know SmartWare was a Japanese only program. Why? Anyone’s guess…

  5. Then it recommends that I update the software, so I download the updater, but it won’t install. The installer starts up, then just aborts without even an error message.

  6. So maybe it is the firmware. Downloaded the firmware updater, and it won’t run either.

  7. But, now the computer boot time has slowed to a crawl. No, no malware. Checked that. But, at least I can see the drive in Windows Explorer now.

  8. But the “Setup drives” button is grayed out. So, I can’t set up my drives.

  9. The “Backup” and “Retreive” buttons are also grayed out. So the ironically named “SmartWare” is essentially worse than useless. It does nothing, but is a drag on system resources.

  10. The Smartware icon in the upper left of the screen is supposed to do something, but it doesn’t do anything either.

   I looked around this board, and tried numerous of the suggested solutions offered by users, but nothing works. And I see almost no posts by WD staffers. Well, I guess this was why the drives were on sale for half price. Time to stop wasting time here hoping for fixes.

Half-price is too low, unless their counterfeit or known defective.