Had access to Shared Network Drive, but Now can't

I’ve been going nuts for the past 6 hours.  Just set up my WD TV Live Plus box.

Instantly was able to access my Servers shared folders.  They contained a lot of movies, music and videos.

They all played flawlessley.  I was able to browse all the folders and files. 

Now whenever I access the servers files, I was prompted for a user name and password.  Something I’ve had for years.  All computers in my home have to do the same to access certian drives.

WD TV Live Plus, prompted me to do the same.  Once entered, I had access to these drives.

After trying it out for about an hour, and turning it off for a while, then turning it back on, I was only able to access the PUBLIC folder on my server.  My: My Documents>My Videos folder.

When checking through them WD TV Live Plus menu, I cannot access the function “NETWORK SHARES” but can Access my Server and only the PUBLIC folders.

I have tried, resetting factory defaults about 5 times, manually inputting an IP address (Static instead of dynamic), disabling my Firewall (Norton 360), even unplugging the WD TV Live Plus power for a while, resetting my router, re-booting my server, checking my EVENT VIEWER (to see if there are any master browser errors/comments) for anything ‘eventful’, checked this forum thoroughly.

I did update my firmware.  But I cannot remember if I did the update AFTER I was using the unit for the first hour, or if I updated the firmware immediatley BEFORE I started using the unit.  

I am very frustrated, because whilst I’m not a SYSADMIN, I am a bit network savvy.  All my machines run on XP Pro SP3.  I was very excited when I found this device initially working flawlessly.  Now, I cannot for the life of me, get back where i originally started.

I cannot even “remove” my server from the list of drives.  The WD TV Live Plus even sees my DirecTV DVR program listings.  They cannot be played though, I am sure due to DirectTV’s proprietairy video formatting used on their DVR’s.

So can someone help remedy this.  I see that this new firmware was published TODAY 2/9/2011. Could this be the issue.  

I even read about people putting the WD TV Live Plus in the refrig/freezer for a while due to thermal issues.  I have a lot of experience with electronics and thermal intermittents (using freeze spray on circuit boards to isolate troubles) and problems like that.  But my networking capabilities on this device are FINE.  I can browse the You tube stuff, and network connectivity/ internet connectivity is not an issue.  

And I firmly believe that my “server” (Win XP Pro SP3), nor firewall, nor router are the problem.  It was working just fine for about an hour.

Thanks for any help. 

BTW: doing the Net View workes fine, all shares are listed.

If I understand your post correctly, your LOGIN info got CLEARED, and it’s logging you on as “Anonymous.”

here’s how to fix this.

Go to NETWORK SETTINGS, and turn OFF “Auto Logon to Network Shares.”

Then select “Clear Login Info.”

Now go browse to your server again.

It will ask you for the UserID / Password.

Fill in the info and confirm you’ve been successful.

Then go back to Network Settings and, if you want it to act like this, turn “Auto Logon…” back ON and you shouldn’t be bothered to put it in again.

By the way, no firmware was published today…  

Tony, Thanks for the help. However that is one of the processes I did. I set the auto login to NO and cleared the login info. It didn’t work. I was never prompted again. I also tried the prossess in reverse order, and still didn’t work. Additionally even when resetting to factory defaults, I was never prompted to login. Now my firmware didn’t “down rev” to the original version when resetting. I kind of expected that. And I was reading on some posts yesterday that Monday the newest version of firmware. I am not infront of the unit now but I do have th 1.014B. Version. Every time I look at my File Management it says NOTHING FOUND! I am just frustrated because the system is so simple to use. I wish I could reset back to the original firmware version 1.013, but it can’t. Let me know if I can try anything else. I am thinking of calling WD for this. They state that I can get 30 days free support from the first time I call. Thanks. I will post again with any results for all to see.


Finally had 2-3 hours to work on this today.  First thing i figured I’d try was to “down rev” my firmware to the 1.03.49.b. Following the Rollback advice from a post in the firmware section.

Ok.  I also re-booted my server.  When the rollback was complete, I started like it was open from the box, when I first got it and hooked it up 5 days ago. 

This is what I get now:  SAME THING!  When going to “browse” any media (video, pix, audio) I am only directed to my server.  And the specific location that I am directed to is my {C:\Windows\my documents} folder.

Like in my earlier post, when I first powered this baby up, i was always prompted for my user name, and password to log into the server.  As I posted before, I did (many times, including tonight) do what you told me by turning off “Auto Login to Shares” and “Clearing Login Info”.  I have never again been prompted to “login” with name and password.

NOTE: when I am looking at my “Media Server” it states the name of the server, and my login name as:

MEDIA SERVER: Satellite: David

My server (Satellite) and Windows Login Name: David, but it always takes my back to my “C:\Documents and settings\David\My Documents” folder   and    NOT  “My Network Places” folder which it originally did, and list all my shared network folders on that server.

I’ve even tried pressing the “reset” button on the side of the WDTV Live Plus box.

After all this again, I updated my firmware to the current version, and I still CANNOT get it to see any shared folders except that one.

Additionally, it wont even see any other computer on my network other than a) my server (and the aforementioned folder) and b) my direct TV DVR file listings, no other computer or other storage device.

I go the the WDTV  menu under Settings: “File Management” selection and it states “No Storage Present”.  When i first hooked all this up, it listed EVERYTHING.

My network settings alone are fine, static and dynamic IP (tried both), subnets, DNS, Gateway…All fine!  I can stream YouTube stuff till I’m blue in the face. Disabled my Norton360 Firewall on the server, permissions on all of these shared folders are available to “Everyone” to “read”, so everyone on the network has access. I haven’t touched any of those permissions in about 3-4 years.

Please anything to reset this would be great.  Should I call tech support? Is this something I should be sending back?

Any advice, even extremely technical would be helpful.  

Thank you.


P.S. Forgot: I did do the “Return to Factory Default” settings, quite a few times in my troubleshooting processes. That only really cleared my video settings, my IP settings, my clock and time zone settings.  But never changed my login settings, or anything like that.

Ok, I’m confused now…

The first things you’re describing are related to NETWORK SHARES.

The rest of your post is all describing MEDIA SERVERS.

They are two totally distinct mechanisms that don’t have anything to do with one another.

Media Servers NEVER will ask you to log in.    DLNA has no security, so it won’t ever ask for a User ID or Password.

The Media Server screens will only show folders that you’ve configured on your PC to be included in the Media Library.

So, exactly which are you trying to work with?

Its pretty obvious, its net shares. I also have the same problem. I have found out, if i first go through fileserver, so i access the nas and then go back to netshares, I can log in. Sometimes it goes directly, sometimes it take up to 20-30 sec. I then have to go back and try again. It didnt work with latest firmware, movies stuttered so I rollback to 1.03.49. Now we can stream wireless 1080p movies with subtitles without any stuttering. It needs a good router and usb dongle that works with wd tv live. I use the cheap tp-link dongle, works like a charm.

(Never posted Feb 15th, re loaded from WDC community saved for me)


Sorry for the confusion.  The selection NETWORK SHARES: I cannot access at all.  It is there, but if I press the OK button, nothing happens, I press the RIGHT arrow nothing happens, I Press OPTIONS button nothing happens.

When I first  hooked it up, and was “playing” with it and watching movies from my server, I really wasn’t paying attention to exactly how I was doing it.  It all seemed very easy and straight forward.

I don’t remember if it was throught NETWORK SHARES or through the MEDIA SERVER selection. 

I DO remember, however, that   A) I was prompted for a password to login to my server, and B) Under FILE MANAGEMENT I would be able to copy/move files, etc.

If I was originally viewing this through NETWORK SHARES selction I didn’t realize it.  But when I went to VIDEO: I saw the shared files from my server; when i went to AUDIO: I saw those folders; Went to PHOTOS: saw those as well.

So if I am not able to select NETWORK SHARES, and have done a lot of troubleshooting, what else could I do?

Did I somehow “Lock up” my unit?  I have tried repeatedly to clear automatic logon and turn it on and off.

I am sorry for the “confusion” but please understand when it was working, that was my first experience with it.  I was learning how to use it.

Thank you for the clarification of the two terms, though.

I guess to answer your question I’m just trying to access my files the way that I originally saw them.  Which is the same way one would see them on a PC running XP: My Network Places.  When any computer on my network accesses their “MY NETWORK PLACES” they will see the network shares from my server.

So still on my network, every PC that is on CAN see those Network shares.  I’ve even checked my network trust level on my NORTON 360, and the WDTV box is a “Full Trust” item.

I CAN see the WDTVLIVE unit from My Network Places under the Local Network, complete with TV icon.

I hope this clarifies my trouble.

??? Would turning off Media Library help


Well, since my post on 2/15 or so I’d spent considerable HOURS trying to get this resolved.

There were no more replies to this thread, and I looked around the various “similar” problems on this Networking board, and General Discussions Board.  Even checked the Firmware board.

The crux of my issue with this box was I was not able to ALWAYS see my NETWORK SHARES.  I could, however, see my PUBLIC folder in the MEDIA SHARES folder.

The “funny” thing is, it would work when IT WANTED to.  Very strange.  I understand how within the Windows networking structure, with the Master Browser, etc.  It can take some time for the computers to see each other.  But with my WD box, I would: turn it off, leave it on overnight, etc. etc.  But to no avail.

Reading through many posts, and continuously checking the other computers on my network, I decided to start digging a little deeper, looking in my Registry in specific places, using my MMC to verify different “services” related to networking, made sure that I have NetBios OVER TCP/IP, etc.

Actually before I made any wholesale changes to any computer, the WD box started working!!!

I didn’t do ANYTHING! So, I go to Video>Network Shares>Server! and I could see ALL the shared folders.  Mind you, this had occasionally happened.  So I “played” with the box for about 15 minutes, everything worked fine, but couldn’t see 3 other workstations on my network.  Keep in mind, all 6 computers in my network can talk to each other and the server, so there wasn’t an issue within my network.

Back to the box:  After about 30 minutes of using it, I dared to turn it OFF.  With GREAT hesitation I did, left it off for 5 minutes, then turned it back on.  Once on, I immediately went to Video>Network Shares>NOTHING.  Ok, went to SETTINGS>NETWORK SETTINGS> NETWORK STATUS: Result, All 3 network items check out OK! My Internet connection, My IP, and my DNS, all OK.

Went back to VIDEO>NETWORK SHARES>SERVER.  Lo’ and behold, it worked.

That was Tuesday Feb. 22, 2011.  I did all the above (last two paragraphs) about 3 more times. No problem.  Now I’m totally befuddled.  Cause, now it’s working like it did when I took it out of the box 2-3 weeks ago.

I ended up tweaking my server a bit after all this, and two of my workstations via the registry, and smaller bugs that really only affected performance. At this point I was committed, and wanted no stone left unturned.

But I’m glad to say that I have been using it for the last 3 days in-a-row, turning the box off at night, and powering it back up next day, and no hitches!

Part of my process last week, when I was having no luck, was I downgraded the firmware to 1.03.49_B , ran it for a while, did a few youtube videos, then allowed the system to upgrade firmware via my internet connection to current 1.04.18_B.  I must’ve done this about 3-4 times.

That didn’t work either way.  I did restart my server a couple of times, prior to tweaking it, but that didn’t do anything.

All the while that I had NO access to NETWORK SHARES, and NO ACCESS to the server (or any other workstation) using FILE MANAGEMENT, I DID have access to my server through the MEDIA SERVER selection.  And those files came up rather quickly.

So, I close this thread with a “SOLVED” but truly unknown as to “how” it got solved.

Thanks to the two people, TONYPH12345 and Hovnarr  who commented with suggestions and insight.

Hi I have a related issue when using network shares: If I set “auto login” On, My Wd tv live Will not connect to My qnap 419. However if i leave it off and at the login promt leave the all ready entered user and password (remembered from last login) and Press ok it logs in like a charm every time. Assuming the auto login feature works by doing just That, i find it mind boggeling that it dosent work. Are there others having this issue? Btw wd: given this is the way I have to login, it would be nice if the ok button on the login prompt was highlighted on entry so I wouldn’t have to skip down down right EVERY time I access my network share.

Nope… Never had that issue.   I have a QNAP TS-410.

What happens when you DO have auto-login turned on?   Do you get an error message, or what happens?  What do the QNAP logs say?

The Auto Login feature with my QNAP is one of the few things on the Live / Live+ that has ALWAYS worked, from the day it first shipped with version 1.01.01.

With auto login turned on I get this error: “this network share cannot be accessed” In the qnap log it says that user “GUEST” has logged in ok. However my login is as admin when it works, and that is also the user that the wd tv live remembers for me when i log in “manually”. I’ve tried clearing the login info on the wd box, but no cure here:( Thanks for the quick reply

I have exactly the same problem but with multiple shares.

The problem presents on:

WD Mybook World

Maxtor MSS


Windows XP

To reiterate, when I first got my box (last year) everything worked fine. Then there was a firmware update and the problem started. When trying to access network shares it would get stuck at “connecting…” for a long time. Eventually it would say it could not connect. Nevertheless, it would access the same drives absolutely fine through their mediaserver functions. As well as that, if I turn off “Auto Login” and use just use the anonymous/no password, the WDTV connects to the same drive immediately. I HAD hoped the issue would be solved in a firmware update but the latest one has actually made the problem worse! I’ve tried googling a solution but most seem to refer to Windows 7 issues so I’d appreciate any help.