[Guide] Rtorrent + Rutorrent

  1. install rtorrent

    apt-get update

    apt-get install rtorrent

    apt-get install screen

  2. install rtorrent config file.

    cd ~

    wget --no-check-certificate https://www.dropbox.com/s/bqa79x54zk29j5l/.rtorrent.rc

  3. make rtorrent folder

▲ Go to dashboard and make folder ‘rtorrent’ - permission : public (Like above)

mkdir /shares/rtorrent/.session

mkdir /shares/rtorrent/downloads

mkdir /shares/rtorrent/watch
  1. install init.d file

    cd /etc/init.d

    wget --no-check-certificate https://www.dropbox.com/s/wxhubj8oi05yvhx/rtorrent

    chmod a+x /etc/init.d/rtorrent

    /etc/init.d/rtorrent start

    update-rc.d rtorrent defaults

  2. install rutorrent GUI (REFER :  https://bintray.com/novik65/generic/ruTorrent)

    cd /tmp

    wget http://dl.bintray.com/novik65/generic/rutorrent-3.6.tar.gz

    tar xvf rutorrent-3.6.tar.gz

    mv rutorrent /var/www/htdocs

  3. Install rutorrent plugins

    wget http://dl.bintray.com/novik65/generic/plugins-3.6.tar.gz

    tar xvf plugins-3.6.tar.gz

    rm -rf /var/www/htdocs/rutorrent/plugins

    mv plugins /var/www/htdocs/rutorrent

※ Option : unpack plungin

rm -rf /var/www/htdocs/rutorrent/plugins/unpack

chown -R www-data /var/www/htdocs/rutorrent/

 7. make id and passwd

htpasswd -cb /var/www/htdocs/rutorrent/.htpasswd yourid yourpassword

chown root:www-data /var/www/htdocs/rutorrent/.htpasswd

chmod 640 /var/www/htdocs/rutorrent/.htpasswd
  1. add apache2 config

    nano /etc/apache2/sites-available/rutorrent.conf

    <Location /rutorrent>
    Order Deny,Allow
    Deny from all
    Allow from all
    AuthName “ruTorrent login”
    AuthType basic
    AuthUserFile /var/www/htdocs/rutorrent/.htpasswd
    Require valid-user

 Ctrl + O , enter, Ctrl + X

a2ensite rutorrent

service apache2 reload
  1. test in your browser

  

Web browser : http://MCIP/rutorrent

  passwd.png

▲ insert your id and passwd (7)

add.png

▲ add torrent file.

※ Option : rtorrent folder for only admin permission

/etc/init.d/rtorrent stop

cd ~

mv .rtorrent.rc /shares/.rtorrent.rc

Go to Dashboard and edit permission

▲ Like above

chown -R admin /shares/rtorrent

nano /etc/init.d/rtorrent

 Line 4 : user=“root” -> user=“admin”

Ctrl + O, enter, Ctrol + X

  1. Mobile app : transdrone

Install transdrone

▲Setting

▲ Add new server

▲ Name : whatever you want

Server Type : rtorrent

IP: internal IP or DDNS

User name : id - (7)

Password : passwd - (7)

Go to Advanced Settings

▲ Port number : 80 or port forwarding port.

SCGI mount point : /rutorrent/plugins/httprpc/action.php

▲ Like above

and go to Optional setting

▲ Server OS : Linux

back 3 times and refresh.

you can see your rtorrnet server status.

  1. Remove

    /etc/init.d/rtorrent stop

    update-rc.d -f rtorrent remove

    rm -f /etc/init.d/rtorrent

    a2dissite rutorrent

    service apache2 reload

    apt-get --purge autoremove rtorrent screen

    rm -rf /var/www/htdocs/rutorrent

    rm -f /root/.rtorrent.rc

2 Likes

LinAdmin7 wrote:

Thx for your suggestion :smiley:

When you do “apt-get update” a whole lot of errors and warnings are displayed.

Have you ever heard of a solution how that mess left by WD software could be repaired?

 

I guess " GPG ERROR"

W: GPG error: http://ftp.us.debian.org squeeze Release: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY AED4B06F473041FA NO_PUBKEY 64481591B98321F9
W: You may want to run apt-get update to correct these problems’

Is it right?

You can fix it very easily.

  1. first part.

gpg --keyserver pgpkeys.mit.edu --recv-key AED4B06F473041FA

gpg -a --export AED4B06F473041FA | sudo apt-key add -

  1. second part

gpg --keyserver pgpkeys.mit.edu --recv-key  64481591B98321F9

gpg -a --export  64481591B98321F9  | sudo apt-key add -

  1. apt-get update.
1 Like

LinAdmin7 wrote:

I had described it at

http://debianforum.de/forum/viewtopic.php?f=9&t=147937

 

Just tried again with the latest firmware and apt-get update does no longer give warnings :smiley:

 

Looks like WD corrected something without saying in the release notes :angry:

 

 

My Cloud is based on Wheezy.

So if you want install this pakage, just restore source list and follow this guide.

apt-get upgrade is really dangerous.

After a restart I get these messages:

[17.03.2014 20:38:14] WebUI started.

[17.03.2014 20:38:15] No connection to rTorrent. Check if it is really running. Check $scgi_port and $scgi_host settings in config.php and scgi_port in rTorrent configuration file.

And all my torrents and RSS feeds are gone.

How can I fix this?

Did you firmware upgrade?

Maybe rtorrent removed.

So you need to reinstall rtorrent.

oygab wrote:

After a restart I get these messages:

[17.03.2014 20:38:14] WebUI started.

[17.03.2014 20:38:15] No connection to rTorrent. Check if it is really running. Check $scgi_port and $scgi_host settings in config.php and scgi_port in rTorrent configuration file.

 

And all my torrents and RSS feeds are gone.

 

How can I fix this?

1 Like

Let me start that I am windows user for 20 years plus, probably like many many other users.  Like many others as well I have little to no knowledge of Linux but I am trying.  Something I found is that rutorrent service seems to stop on it’s own.  

My WD MyCloud does not show anything immediately visible as to why.  I just merely ssh and start the service.

My question is this.  Can I make a script that checks for the service status and starts the service accordingly?

I know some about Windows Scripting, not useful on Linux I know but a good base for understanding I guess.

My Setup:

MyCloud 2TB

MyBook 2 TB

Vantec 4 Bay Raid in 0 with 3 drives.

Very well put together guide and all is working well…Kudos to you

Well, I have tried Transmission from another thread here and it has remained active since install.  To the others having issues with rutorrent, I recommend trying Transmission to see if you experience the same issues being experienced with rutorrent.

Excellent guide but unfortunately the dropbox links no longer exist.

Using a comination of your post and a Korean post  http://www.wsgvet.com/bbs/board.php?bo_table=iomega&wr_id=771&device=mobile I manged to get a working copy of rtorrent installed on my device. I take no credit for creating this guide, all credit goes to the origonal posters.

I installed firmware update 024303-022-20130916  https://www.dropbox.com/s/zz8gpalv2w8rmr7/apnc-024303-022-20130916.deb

Using Putty Terminal from windows I then proceded to use the following comands

apt-get update

apt-get install rtorrent

apt-get install screen
  1. install rtorrent config file.

    cd ~

    wget -O .rtorrent.rc https://www.dropbox.com/s/h3pwxtb0l8jrwsn/.rtorrent.rc

  2. make rtorrent folder

▲ Go to dashboard and make folder ‘rtorrent’ - permission : public (Like above)

mkdir /shares/rtorrent/.session

mkdir /shares/rtorrent/downloads

mkdir /shares/rtorrent/watch
  1. install init.d file

    cd /etc/init.d

    wget -O rtorrent https://www.dropbox.com/s/f41mggk1ihbzqqc/rtorrent

    chmod a+x /etc/init.d/rtorrent

    /etc/init.d/rtorrent start

    update-rc.d rtorrent defaults

  2. install rutorrent GUI (REFER :  https://bintray.com/novik65/generic/ruTorrent)

    cd /var/www

    wget -O rutorrent-3.6.tar.gz http://dl.bintray.com/novik65/generic/rutorrent-3.6.tar.gz

    tar xvf rutorrent-3.6.tar.gz

    rm -f rutorrent-3.6.tar.gz

  3. Install rutorrent plugins

    cd rutorrent

    rm-rf plugins

    wget -O plugins-3.6.tar.gz http://dl.bintray.com/novik65/generic/plugins-3.6.tar.gz

    tar xvf plugins-3.6.tar.gz

    rm -f plugins-3.6.tar.gz

    rm -rf /var/www/rutorrent/plugins/unpack

    chown -R www-data:www-data /var/www/rutorrent/

 you may need to type this one in # c h o w n   - R   w w w - d a t a : w w w - d a t a   / v a r / w w w / r u t o r r e n t /

 7. make id and passwd

htpasswd -cb /var/www/rutorrent/.htpasswd yourid yourpassword

chown root:www-data /var/www/rutorrent/.htpasswd

chmod 640 /var/www/rutorrent/.htpasswd
  1. add apache2 config

    nano /etc/apache2/sites-available/rutorrent.conf

    <Location /rutorrent>
    Order Deny,Allow
    Deny from all
    Allow from all
    AuthName “ruTorrent login”
    AuthType basic
    AuthUserFile /var/www/htdocs/rutorrent/.htpasswd
    Require valid-user

 Ctrl + O , enter, Ctrl + X

a2ensite rutorrent.conf

  

/etc/init.d/apache2 reload

  

a2enmod authz_default

a2enmod auth_basic

/etc/init.d/apache2 restart
  1. test in your browser

   passwd.png