[GUIDE] Install Transmission 2.77

Herokolco wrote:> The only thing that confused me that I can’t see the download folder TR-Downloads in /DataVolume/shares/Public If I understand correctly incomplete torrent files are  temporarilystored in /root/DataVolume/shares/Public/TR-Downloads When the file has finished downloading it is finally moved to /DataVolume/shares/Public/TR-Downloads


Thanks for great guide!

I edited the json file so downloads in progress go to Public/TR-INCOMPLETE

Once completed it get’s moved to Public/TR-Downloads

You need to stop Transmission, delete the json file, and create a new json file

/etc/init.d/transmission-daemon stoprm /root/.config/transmission-daemon/settings.jsonnano /root/.config/transmission-daemon/settings.json

Copy the new json text below and paste it into your nano window

    "alt-speed-down": 50, 
    "alt-speed-enabled": false, 
    "alt-speed-time-begin": 540, 
    "alt-speed-time-day": 127, 
    "alt-speed-time-enabled": false, 
    "alt-speed-time-end": 1020, 
    "alt-speed-up": 50, 
    "bind-address-ipv4": "", 
    "bind-address-ipv6": "::", 
    "blocklist-enabled": true, 
    "blocklist-url": "http://www.bluetack.co.uk/config/level1.gz", 
    "cache-size-mb": 4, 
    "dht-enabled": true, 
    "download-dir": "/DataVolume/shares/Public/TR-Downloads", 
    "download-queue-enabled": true, 
    "download-queue-size": 5, 
    "encryption": 1, 
    "idle-seeding-limit": 30, 
    "idle-seeding-limit-enabled": false, 
    "incomplete-dir": "/DataVolume/shares/Public/TR-INCOMPLETE", 
    "incomplete-dir-enabled": true, 
    "lpd-enabled": false, 
    "message-level": 2, 
    "peer-congestion-algorithm": "", 
    "peer-limit-global": 240, 
    "peer-limit-per-torrent": 60, 
    "peer-port": 51413, 
    "peer-port-random-high": 65535, 
    "peer-port-random-low": 49152, 
    "peer-port-random-on-start": false, 
    "peer-socket-tos": "default", 
    "pex-enabled": true, 
    "port-forwarding-enabled": false, 
    "preallocation": 1, 
    "prefetch-enabled": 1, 
    "queue-stalled-enabled": true, 
    "queue-stalled-minutes": 30, 
    "ratio-limit": 2, 
    "ratio-limit-enabled": false, 
    "rename-partial-files": true, 
    "rpc-authentication-required": false, 
    "rpc-bind-address": "", 
    "rpc-enabled": true, 
    "rpc-password": "{5d73272dade2dccb326e823e555a8bccd6c235f2SkqI2LBJ", 
    "rpc-port": 9091, 
    "rpc-url": "/transmission/", 
    "rpc-username": "", 
    "rpc-whitelist": "", 
    "rpc-whitelist-enabled": false, 
    "scrape-paused-torrents-enabled": true, 
    "script-torrent-done-enabled": false, 
    "script-torrent-done-filename": "", 
    "seed-queue-enabled": false, 
    "seed-queue-size": 10, 
    "speed-limit-down": 100, 
    "speed-limit-down-enabled": false, 
    "speed-limit-up": 100, 
    "speed-limit-up-enabled": false, 
    "start-added-torrents": true, 
    "trash-original-torrent-files": false, 
    "umask": 0, 
    "upload-slots-per-torrent": 14, 
    "utp-enabled": true

Hit control and o

Hit enter

Hit control and x

This will save your edited file

Change json permissions

chmod 600 /root/.config/transmission-daemon/settings.json

Restart Transmission

/etc/init.d/transmission-daemon start

As soon as you start a download it should create Public/TR-INCOMPLETE

Once the download has finished it should create Public/TR-Downloads and move the completed file there

Works perfect here

I edited the rar script guide a little… I need a torrent to a SMALL .rar file so I can test the script

Thanks :slight_smile:

Hi nfo,

Did you get my torrent via PM?

On a related note, after installing Transmission, pyLoad and Webmin yesterday, I noticed that the disk doesn’t sleep anymore (light stays green). That would be understandable while I was downloading/seeding something, so first, I’ve tried removing every torrent and download from pyLoad, but it still doesn’t sleep.

So, I went on and killall transmission-daemon and also stopped the pyLoad/pyThon process, but still, the drive doesn’t sleep.

Do you have any clue as what might be going on or how to check what’s keeping the disk awake?

@Timmy yep I sure did, thanks for that. I put a working Unrar Unzip Guide up on page 1… I had to use a different script and I don’t think this one will unrar a multi-file rarset… I’m sure someone can incorporate it at some point though. I will check on the sleeping thing, but I’m pretty sure mine sleeps (My LED doesn’t work but I can touch the drive and tell)

I have sabNZB, pyLoad, webfs, Transmission, Midnight Commander and znc installed on mine and I know it was sleeping up until a few days ago when I put transmission on…

I am still running 02.11.09-053 on my test MBL though but I did upgrade to the latest firmware to test my guides and they worked fine. I then just used the resetbutton script to downgrade back to my custom firmware rootfs.img I made with all my mods installed.

Gimme 10-15 mins and I will report back

1 Like

My drive is sleeping… Do you have itunes sharing or remote access enabled? Not sure how I could tell what is keeping your drive awake besides the fact I have those disabled and am running a lower firmware version than you are on your MBLDUO.

Did your debrick go ok with the mhbookworldwiki images btw?

Hi again nfo!

I haven’t debricked yet because I’m still getting the data out of the disks first (is taking like 30 hours), plus I’m busy with some other stuff, but hopefully I’ll be trying it soon.

I don’t know what is keeping the disks awake. Do you have all those daemons running when the disk sleeps, or do you have to kill some of them to stop using the disk and letting it spin down?


They are all running

Hi nfodiz, installed and tested transmission on mbld. Now i’m enjoying it.

You’re welcome, it really is a nice program

NFODIZ, you are THE man! This is the second time your hard work and knowledge saved my a$s :) 

Thank you! (and, yes, I pressed the kudos star ;))

LOL, glad it worked… I know alot of people were saying Transmission didn’t work on the newer firmwares via apt-get I think so I put together this guide to install from optware and it worked like a charm on the newest MBL firmwares.

Thanks for the Kudos!

And since now we have optware installed I have also threw in the Midnight Commander :catvery-happy:

ipkg install mc

 not to mention that on MBLD you have PLENTY of space and not too shabby HW to run all sort of apps that optware repository provides. There was certainly more than one bird killed with that stone…

Thank you nfodiz!

Excuse my Linux noobinesh… but what’s the difference between apt-get and optware? I see them as two different “Markets” or “Repositories” from where to download and install stuff, am I right? apt-get is the most widely available and optware you have to install yourself…

What I wonder is what’s the difference between installing Transmission via one or the other? Does it break stuff with apt-get but works OK with optware? If so, why is that, shouldn’t be the same with both?

I ask these questions so you can enlight me with your Linux knowdlege :slight_smile:

With at least latest two releases of firmware for MBLD one would get errors after trying to install transmission with apt-get.

Now you install optware (which is is an advanced package manager used for distribution of additional software packages on various operating systems) and than you can install transmission or any of other packages available for powerpc architecture (the list is VERY long).

So it is a kinda of workaround for the problem that have arisen with latest updates from WD.

Thanks for the explanation. Do you know why *technically* it wasn’t working anymore with apt-get? What changed or what apt-get does different than ipkg?

Finally, is there a list of those lot of apps that can also be installed with optware?


I very much like the idea of having the .torrent files stored on the DataVolume.

nfodiz wrote:

Create a folder called torrents in your Public folder


SSH in and issue

rmdir /root/.config/transmission-daemon/torrents
ln -s /DataVolume/shares/Public/torrents /root/.config/transmission-daemon/torrents

Could we incorporate this into the initial guide? If it’s a yes, then don’t forget that some people may already have files in the /root/.config/transmission-daemon/torrents directory that could prevent them from using the rmdir command…


@OceanOver, sure I can add it in there later but doesn’t transmission delete the .torrent file after you remove it from the download list? I haven’t found a way to stop it from deleting the file.


I can now confirm that both of the instructions in this guide are working correctly.

The “Install Transmission v2.77 Guide” and the " Auto UnRAR & UnZIP Script" have both been tested and are operating exactly as they should.

I have tested the install procedure you supplied for the Transmission installation and I have tested a muti-set RAR download.

  • Transmission automatically generates a TR-INCOMPLETE directory during the first use.

  • It then creates a TR-Downloads directory once the download is complete and moves downloaded archive into this directory.

  • Finally, the script creates an additional folder inside the newly downloaded directory (called “extracted”) and eventually decompresses the file into it’s original format.

  • (Bonus) The .torrent file is stored in the “torrents” folder (easily accessible for those who opted to follow the additional instructions in nfodiz’s replies).

I then tested this uncompressed file on a Smart TV (via the Twonky Media Server) and everything came up Milhouse. Well done & thank you! A couple of Kudos Stars coming your way.


@OceanOver so multi-file rarsets extract properly with the rar script? I wasn’t able to test




nfodiz wrote:



^ Yes. Definately.

nfodiz wrote:



^ Untested at this stage… Sorry.

1 Like