[GUIDE] How To Unbrick your 2TB/3TB/4TB My Cloud

I know that but you are the only one that has posted a full how to guide of fixing a bricked device so I thought that you would help me somehow

I am posting guides for the first/second gen single bay My Cloud that were done or hosted by user Fox_exe. I do not have a My Cloud Home so I have no experience with that device. User Fox_exe does have a My Cloud Home subforum on their website, not sure if there are any instructions in there for reinstalling the My Cloud Home OS to a hard drive.

https://fox-exe.ru/WDMyCloud/WDMyCloud-Home/

https://fox-exe.ru/WDMyCloud/WDMyCloud-Home/Original/ - This is original disk image and instructions how to install it on disk.
Not mine. Use at your risk.

Thank you I will try and will write about my success or failure

I managed to somehow boot up the device. It is showing in my router as MyCloud device but i cannot access it. What is the procedure for that? I tried 40s reset button, it did a hard reset, blinking led and two times reset. Now the light is steady white but i cannot access it. Do you have a solution for this?

Thank you for your time

Six years later, this guide is still accurate. Gen 1 my cloud single 4tb bricked when it fell while in use, solid red and dead. Ordered a WD red 6tb drive only. Followed original guide up to and including step 9. Then I rebooted to grub recovery cd, accessed new 6tb drive again with GParted and deleted the ext 4 partition Id #4 and recreated to use all unallocated free space. This gave me 5.9 tb for backups in ext partition.

Reassembled unit and came up to solid red, but able to access via http web and performed quick factory reset. On reboot, all 5.9tb space available to unit. However, unable to update firmware via auto download, so I downloaded latest gen 1 firmware (.deb file not zip)from web site and manual update of firmware from web interface worked on first attempt. My bricked WDMycloud is back better than ever with an additional 2tb of space. Can’t thank you all enough! Updated build steps below:

What To Do

  1. Burn the SystemRescueCD.

  2. Unzip the 2 or 3TB Virgin Image, and copy the mycloud2tb.img file to the 8GB+ USB Drive.

  3. Disassemble your My Cloud. 2.8k

  4. Pop the Linux RescueCD, the USB Drive, and the WD Hard Drive into the PC. (It is recommended you disconnect any other drives in your PC, to avoid confusion.) Boot off the CD. For Dell, press F12 during BOOT to get the option.

  5. When the RescueCD finally boots, start the graphical environment by typing STARTX.

  6. Click on the Gparted icon it task bar at bottom, and use it to determine what devices are what. (click at upper right to change devices) Take note of your Hard Drive (usually /dev/sda) and your USB Drive (mine was /dev/sdb). The partitions/sizes should be a big hint, especially if you have no other drives connected.

  7. Close GPARTED then click on Terminal Window icon, and enter the following commands in the terminal window:
    mkdir /mnt/usb
    mount -t ntfs /dev/sdb1 /mnt/usb
    ls /mnt/usb

  8. ‘mycloud.img’ should be listed in results of list command above. NOW it’s time to overwrite everything on your new hard drive…. The next command is Disk Duplicate and copies the image found in In File IF (the USB drive) to Out File OF the new hard disk drive
    dd if=/mnt/usb/mycloud2tb.img of=/dev/sda

  9. Be patient, there will be no response for 5 minutes. Your hard drive is being overwritten and that takes some time. Your result should be
    10240000+0 records in
    10240000+0 records out
    5242880000 bytes (5.2 GB) copied, xxx.xxx s, xx.x MB/s.

  10. Reboot the Rescue CD (Linux), start graphical interface with STARTX

  11. Single click to start GPARTED and access newly rebuilt drive. Open up partition table and take a look at what you have. I had numerous partitions and large amount of unallocated space available.Lets use available space.

  12. Delete the EXT4 partition (this is the largest partition numbered 4 in my build).

  13. Create a new partition 4 of type EXT4 with GPARTED using the balance of unallocated space.

  14. Write the changes to the drive using GPARTED to finalize the build

  15. Shut down Linux

  16. Remove the new WD Red hard drive from build PC and reattach to logic board of WD MyCloud

  17. Connect network and power. My drive comes up to solid RED light (again).

  18. Access the drive as if it were new using http://mycloud.com/setup

  19. My drive accessible at 192.168.1.3, same as original config. Can manage at

  20. Drive showed only 1.5TB of storage and has lost access to its files, also firmware is older at ver 03.00.232. All of this is causing the solid RED light

  21. Go to Settings, then UTILITIES tab, choose the SYSTEM FACTORY RESTORE and take QUICK RESTORE, system will spin for a while, then reboot. (NOTE, if you take option for FULL RESTORE, be prepared for hours or days of waiting as this process is intended to cleanse your personal data and writes patterns of data to the entire drive as a way to delete personal data. Reports of this running 24 to 48 hours are posted. Don’t do FULL RESTORE.)

  22. When drive reboots, all of the new storage space was available (5.9TB in my 6TB drive!!)

  23. Still had error Solid RED due to Firmware. I attempted to download and install firmware recommended AUTOMATICALLY with CHECK FOR UPDATE. System would not allow the firmware upgrade, it errors out on a space error or not able to download error. I found the firmware for Gen 1 on this page:
    WD My Cloud v3.x, v4.x and v2.x Firmware Versions Download Links

  24. Downloaded the .deb file and then from SETTINGS, FIRMWARE and MANUAL FIRMWARE option, was able to upgrade from version V03.00 to V04.05.00-342.deb

  25. The unit rebooted to BLUE light, with white background on new administration panel, I completed a new configuration setting Time Zone, adding a new user and adding a new share. Now everything is fine, and able to access from same old links, no problems saving backups to the drive.

Yes I have done this but still no success. I have WD My Cloud HOME 8TB device with 4TB WD RED NAS drive. I cannot manage to access it. I can see it has and dedicated IP address from my router. Can I use that to bypass /setup guide?

Hello there
I bought a 2nd generation 3 TB device. but there is no hard disk. I need an image. Is there anyone to share an image? I ask for help.

I used the links off this youtube video for the 4 TB image it worked. The instructions at the start of this thread worked for my gen1 4 TB no issues.

Are the links in the video for gen 1?

I used the 4TB one last night it is GEN1. The 3TB image is GEN1 also but not a virgin image there is a share on it. So if anyone uses the 3TB don’t forget to do a factory restore first thing after finishing.

fist thank u for help. i need 2. gen 3tb image. Is there anyone to help me? pls :slight_smile:

1 Like

Hello,
My MyCloud / 3TB / P/N: WDBCTL0030HWT - 00 with latest firmware just not working. I have solid amber light on it. I have contacted WD Support, no help so far. Do you know where I can find the virgin disk for my MyClould ?

I had the same issue …
I have then found a working solution …

After downloading and mounting the given images … MyCloud started successfully …
Thanks to luiz_Balestreri

Thank you mate. I solved that issue in 2018. thank you for carrying so much about that.

same here if you find 1 let me know and i’ll do the same. thanks

Still working!
Actually, I took a short cut:
(1) I downloaded the https://www.balena.io/etcher/, as suggested by SimonCraddock;
(2) then I downloaded the 4TB image from post 246;
(3) copy the 4TB image for the new HDD using the software installed in step (2);
(4) access the UI from the browser and performing a SYSTEM FACTORY RESTORE (step 21 in [GUIDE] How To Unbrick your 2TB/3TB/4TB My Cloud);
(5) manually update the firmware (step 24).
Now My Cloud 4TB is back on track.
Thank you, guys!

despite the img of the disk is not longer avaliable, i have found a different solution based on the points 12 to 17 of the first post:
i had actived the ssh daemon from the user interface, connected with putty at the ip of the nas, connected using the temporary password (root / welc0me) , and after changed the root password i followed the instruction on gparted to wipe and recreate the partition 4 (with the same start and end point of the previous partition!!), then i had a factory reset and now the NAS has again 4TB instead of 2GB!!

I have a 3TB My Cloud, probably Gen1 since I got it from around 2015. I’ve been updating the OS over the years - I had been using OS5 at the time. Anyway, it crashed while I was trying to copy some large files from the My Cloud to an internal hard drive. Just flashing blue lights, absolutely no way to access it from the interface, online dashboard, or app. Support said it was rebooting or rebuilding its index, but this went on for over a week with no progress. Deciding it was bricked, I removed it from the enclosure and connected it to my PC via SATA, then copied the files over. So I’ve got my files backed up, but no disk image.

I use Ubuntu, so I thought I could follow these unbricking guides using the Gnome Disks utility. I downloaded a copy of WDMyCloud3TBVDI.img from one of these support threads, and used the “restore disk image” option in Disks to write it to the My Cloud HDD. I couldn’t mount the HDD on Ubuntu, but the partitions looked right on the GUI so I decided to proceed. Once I reattached the board and all the cables, I got the typical green lights on the Ethernet port but a flashing red light on the front. I was totally unable to access the drive via any network tools and the light stayed flashing red for hours. I tried the 40-second reboot and power cycling, no change.

Next I tried downloading a more recent firmware image, extracting rootfs.img, and using “restore disk image” on Gnome Disks to write that to both Raid partitions. The results were the same - red blinking, no network access. I then used “restore disk image” from the Gnome Disks to once again write WDMyCloud3TBVDI.img to the HDD, just to undo that last RAID edit. Per an earlier comment in this thread, I tried reformatting the filesystem on partition 3. This seemed to make some difference, as I was able to mount the drive on Ubuntu. But once again, red blinking and no network access once I attached the hdd to the board and cables.

Anyone have any ideas? Could it be an incompatible disk image, something wrong with the board, wrong choice of tool (Gnome Disks vs command line)?

One must know the version because the files used and methods used to unbrick may not be the same. The gen 2 single bay My Cloud has different hardware and uses different firmware that is incompatible with the gen 1 firmware.

Look at the bottom of the single bay/single drive My Cloud enclosure for the P/N number.
First gen v4.x firmware: P/N: WDBCTLxxxxxxx- 00
Second gen v2.x firmware: P/N: WDBCTLxxxxxxx- 10

When partitioning the hard drive for use in the single bay My Cloud enclosure, its important to use the exact values. Do not adjust them in any way or round them off.

Note: The My Cloud Home is not the same as a My Cloud unit. The My Cloud Home uses different firmware and has a different operating system.