[GUIDE] How To Unbrick your 2TB/3TB/4TB My Cloud

Excuse my english. I’m French.

Greats. MyCloud works perfectly with 250G image.

  • dd command with 250G image.
  • format sdb4 in ext4
  • extend sdb4 with unused space
  • recreate raid partion : mdadm --create /dev/md0 --level=1 --metadata=0.9 --raid-devices=2 /dev/sdb1 /dev/sdb2 (without this command, unable to mount /dev/md0)

I want to use this thread to upgrade an original WD Mycloud running 4.x firmware from 4TB to 8TB.

Is 8TB possible? Would I use gparted to get the correct sector sizes? Or would quick factory restore automatically resize the 2TB img provided in this thread to 8TB?

Anyone sucessfully done this with 8TB? Thx!!

Yes an 8TB drive will work with the first gen v4.x My Cloud enclosure. See the following discussions where 8TB is being discussed.

1 Like

thanks!!

Hi Louis,

thank you for the great guide you created here. One Q: how did you create the.img from your own device? With command line or dashboard?

Thank you very much.

Hippy

Thank your very much for the fast response @cpt_paranoia
I’ll give it a try as soon as I’ve my Gen2 MyCloud.

I’ve another issue and I couldn’t find a solution yet, so I Hope you can help me…
here we go:
I installed the clean Debian with OMV. Everything was fine and I played a little bit with that.
After that, I decided to unbrick my 3TB MyCloud and that went well too.
All my data and files were safe as well but I could only see the full storage was 2TB (300GB free) and not 3TB (1.3TB free).
I reset the firmware back to factory state and now the dash shows me the full 3TB (with 2.97 TB free) storage. I think, I’ve unfortunately deleted all files there :frowning:
The Q:
Is there a chance/way to recover my date/files & backups (1.7TB)?

Best
Hippy

Hey guys,
during the unbricking of my wd my cloud gen 2 (single bay) I get this message after 2nd partition:

parted /dev/sda
mklabel gpt
mkpart primary 1049kB 2149MB
mkpart primary 8591MB -1MB

> The resulting partition is not properly aligned for best performance

Does anyone have any solution?

Best
Hippy

Edit: I’m using a wd 3TB red hdd.

1 Like

There is always a way to recover your files unless you write over them while talking about a HDD. Plenty of tools can be used. You should try using Linux for this task but need to attach your HDD to your computer and either have Linux installed or run a Live CD.

You can find many of these here.

EDIT:
Recuva has support for ext4 file system partitions. To use it under Windows you must first install ext2fsd and mount the partition you want. Afterwards you can use the fast and efficient Recuva made by the creators of Ccleaner. It works fast and with a very intuitive UI.

1 Like

Hi

Thank your for great efforts but i have issue when i make (mkpart primary ) command ask start? and i write 9428992s and ask me for end? my hard is 4TB i don’t know what is the parameter should be entered , finally when i complete with out enter this value (end?) my cloud flashing light red

i need end of partition for 4TB??

I can not do that.
Please, help me!
Loads the image. Instead of 5.2 Gb and waiting a few minutes
ends after 4 seconds with 15 MB loaded.
As I check in Gparted it looks normal but after starting the device heats up very much and nothing happens.

Edit…

I’ve already dealt with the problem, there are errors on the disk sda1.
I did the same thing on my Seagate 2Tb and everything went quickly and painlessly.

Now I have a blue light on my cloud but I can not update the firmware in any way! WDMyCloud v03.00.03-413: Core F / W does not want to jump with an automatic or manual update from the file.
How to solve it?

Hi friend, am having a problem with my WD My clud, it seems that the hard drive is like moving a lot inside of the slot of my WD My Cloud, and I want to use my hard drive as a solid state drive, due to this two factors explained, I want to replace my hard hard drive with a Solid State Drive, and I need to know the model of the SSD that best fits with my WD My Cloud, so I can remove it whenever I want and to take it with me.

Hi folks,
I’m trying to unbrick my mycloud gen2 with this tutorial foxys_guide and everything running as expected till the very last step.
When I try to upload the firmware the upload page is hanging at 0% , the red LED stops blinking, and its permanently on. Any idea?
Many thanx!

1 Like

I got a Mycloud board off ebay. WDBCTL0020HWT.
Got a 3 TB wd drive and piut the 3TB image on it.
Magic happened and I got a Blue light.
Trouble is there is on 1.5GB of free space on it . Anyone, can you publish the partition table for yout 3TB mycloud?
min had a 1 mb partition
a 128 mb partition
and a 2.73 TB partition (unformatted)
But the mycloud ap says only 1.5gb free space.

Hello,

Do I really need a CD reader?
We are in 2018, no one has it anymore.

I would like just to see my files, copy them into my other HD and send this MyCloud to RMA.

My files which I know are here, are not shown.

Can anyone help me?

Check the Public folder. Never mind. Didn’t see that the Public folder has 0kb.

If using Windows 10 the following discussion may be helpful if one has removed the hard drive from the My Cloud enclosure and it attempting to read it’s contents.

same issue here. seem to be stuck as any ethond I try to use fail (recovery, USB or load the files to the partition of my 8TB Red directly all fail to get my cloud to stay on blue.)
I have a feeling that its because when I use parted on my linux box and force the partitions when I mkpart primary xxxxx xxxxxx , using “I” to ignore the error:
The resulting partition is not properly aligned for best performance
my partitions are not the correct size or they don’t start with the correct offset.