[GUIDE] How To Unbrick your 2TB/3TB/4TB My Cloud


#122

Is this a gen1 or a gen2? Gen1 uses firmware 4x and gen2 uses firmware 2x.


#123

It is Gen1. Restored the image using Disk Utility in Ubuntu and now it has successfully written the entire image. Reassembled and trying to boot. Will get back with the results soon.


#124

Hurray!!! It worked… I have successfully unbricked my Cloud. Initially it showed 1.5TB free, did a Quick Restore and now it shows the entire 3TB. Thanks for the guide and image. Now should I update to recent firmware? Currenly, WDMyCloud v03.03.01-156 : Core F/W is installed and new firmware shows WDMyCloud v04.04.05-101. Should I update it or retain with the old firmware?


#125

update to the latest.


#126

Thanks RAC


#127

Hello,

Can I use a USB dockstation for mounting the WD Mycloud SATA disk to laptop?
What should be the main point to pay attention? Can I use the exact commands written in the quide? (like dd if=/mnt/usb/mycloud2tb.img of=/dev/sda) or should the guide needed to be changed for USB dock station?

Thanks…


#128

Thanks a lot all who contributed this topic. I’ve carefully read all of the comments. You are really life saver. @eriffoorp I appreciate for the 250GB image.

My WD Mycloud was not booting after I ran apt-get update command.
However I’ve successfully recovered my WD Mycloud 3TB.

What I did:

Part 1 (Installing the image and test if boots the MyCloud)

- Installed gparted to raspberry pi
- Connected the WD HDD with SATA-USB dock.
- Unzipped the 250GB image to USB
- Umounted /dev/sda4 on raspberry
- DD'd the image to /dev/sda as it is mentioned in the first post
- Tried booting the hdd on mycloud and it is successfully booted. Blue light and UI accessible. 

The next step is to extend the filesystem to 3TB. I tried gparted to resize the partition but I experienced it takes a few days or a week, this option is out of scope my maintanance… FYI
It is better to remove the partition /dev/sd4 and re-create.
Follow Part 2

Part 2 (Extend the file system to 3TB)

- Removed the hdd from mycloud and attached to raspberry again over usb dock station 
- Umounted /dev/sda4  (xterm)
- terminal window. (xterm)
	parted /dev/sda
		Enter the following commands in the (parted) prompts:
		
		unit s
		
		P
		
		rm 4
		
		mkpart primary
		
		File system type?   [ext2]?
		ext4
		
		Start?
		9428992s
		
		End? 
		5860533130s      ---> This is for 3TB
		
		Warning: You requested a partition from 9428992s to ……………..
		Is this acceptable to you
		Yes/No?
		Yes
		
		quit
- Back to the command prompt.. (You are already the correct place after you type quit above)
- Type sync

For next step I used quick format rather then factory reset etc. on my cloud. This way is very short like a minute.

Part 3 (Format the /dev/sda4)

- Quick Format the partion (xterm)
	mkfs -t ext4 -E lazy_itable_init=1 /dev/sda4

It is now 3TB.

Plug it the HDD to mycloud and run. The led should be blue and storage should be 2,9TB available.

Informative for non 3TB users:

To find the first and last sector gparted is your helper.
Right click the sda4 and unallocated, in information tab you will see the the first and last sectors.


#130

Why would you try running it on a Pi? They have very different hardware. (Different NIC, Pi does not have SATA… etc.)

Or, do you mean just the usermode parts? (daemons, web interface, et al?)


#131

This guide is great. My 6TB My Cloud drive is now showing a solid red led. I plugged the drive in a SATA drive and using this guide, I was able to re-build the partitions. However when I put the drive back into the WD My Cloud casing, start up the drive again with a wired network cable connection, I still get a solid red led.

Upon pinging IP, I get no response. I don’t even see the device with an assigned IP in my router. If I plug the hard drive into my SATA drive via USB, Windows picks up the drive as multiple drives and prompts whether I wish to format each one. I cannot access the Dashboard.

Any help on trying to fix please…

Gdisk output is as follows:

GPT fdisk (gdisk) version 1.0.1

Partition table scan:
MBR: protective
BSD: not present
APM: not present
GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sdc: 1465130646 sectors, 5.5 TiB
Logical sector size: 4096 bytes
Disk identifier (GUID): B452EC0D-7342-4B60-AD11-C00AE38E4E4E
Partition table holds up to 128 entries
First usable sector is 6, last usable sector is 1465130640
Partitions will be aligned on 256-sector boundaries

Total free space is 30859 sectors (120.5 MiB)
Number Start (sector) End (sector) Size Code Name

1 1032192 5031935 15.3 GiB FD00 primary
2 5031936 9031679 15.3 GiB FD00 primary
3 30720 1032191 3.8 GiB 0700 primary
4 9428992 1465130495 5.4 TiB 0700 primary
5 9031680 9226239 760.0 MiB 0700 primary
6 9226240 9422847 768.0 MiB 0700 primary
7 9422848 9424895 8.0 MiB 0700 primary
8 9424896 9428991 16.0 MiB 0700 primary


#133

Thanks nnnn_mm. I updated my original post with the information based on your questions…

shadow21


#134

Thanks for the guide. I created another mirror of the 2tb virgin image:
https://a.pomf.space/oeddueplqtjh.7z


#135

Hi guys, I have problem with unbricking second generation of WdMC (firmware version 2.0xx) so this images don’t really work. I always get red blinking light after restore.

If anyone could upload image of never version of WDMC?

Tried the methods of uploading recovery image via USB (telnet) not working :frowning:

Any help would be great. Thanks.

Btw I’m trying to use 1tb wd green drive.


#136

Hi I’m struggling with second generation of WdMC, would you be willing to upload the image to other location? This link does work for me (when I press download nothing happens)

Thanks for help


#137

Hi,

I receive “access denied” when I run the command “mkdir /mnt/usb”

Do you have any idea how can I solve this issue?

Thanks’


#138

Excuse my english. I’m French.

Greats. MyCloud works perfectly with 250G image.

  • dd command with 250G image.
  • format sdb4 in ext4
  • extend sdb4 with unused space
  • recreate raid partion : mdadm --create /dev/md0 --level=1 --metadata=0.9 --raid-devices=2 /dev/sdb1 /dev/sdb2 (without this command, unable to mount /dev/md0)

#139

I want to use this thread to upgrade an original WD Mycloud running 4.x firmware from 4TB to 8TB.

Is 8TB possible? Would I use gparted to get the correct sector sizes? Or would quick factory restore automatically resize the 2TB img provided in this thread to 8TB?

Anyone sucessfully done this with 8TB? Thx!!


#140

Yes an 8TB drive will work with the first gen v4.x My Cloud enclosure. See the following discussions where 8TB is being discussed.


#141

thanks!!


#142

Hi Louis,

thank you for the great guide you created here. One Q: how did you create the.img from your own device? With command line or dashboard?

Thank you very much.

Hippy


#143