[GUIDE] Debrick a completely dead MyCloud

This was the only solution that worked for me.  I have the 4TB model and flashed it with the 2TB image.  I was able to resize it with my Linux computer using fdisk, deleting the ext4 partition and creating that same partition number again using all the space available.  The WD software automatically formatted the blank partition.  So this was a quick fix that works well.

1 Like

Glad to hear! Thanks for the resize tip for 4TB. If anyone would be so kind as to point me at a full virgin image for the 4TB, I’ll gladly update the original post.

Hi !

I have restored my 3TB with a 2 tb img. It works fine, but only with 2 tb free space :frowning:

I try to resize by following the guide, but when i do this, i Can acces the drive? My cloud, is just blinking blue, but i can acces either the Dashbord or any mountet drives :frowning:

Does anyone know where to get a 3tb img?

thomas88 wrote:

Hi !

 

I have restored my 3TB with a 2 tb img. It works fine, but only with 2 tb free space :frowning:

 

I try to resize by following the guide, but when i do this, i Can acces the drive? My cloud, is just blinking blue, but i can acces either the Dashbord or any mountet drives :frowning:

 

Does anyone know where to get a 3tb img?

It is not really necessary to have a 3TB image.

Describe how you tried to resize it, most probably you did not exactly what is required.

Thomas, for the resized partition, try formatting it as ext4. That may fix the issue

Hi !

I did as describe :slight_smile:

dd the 2tb img to my harddrive. Plug it in the case and i works fine (just with 2tb free space)

Took it out and in to my computer and open Gparted and resize it as Ext4.

Plugged it out and put it back to the case.

The flash just light blue, and i can’t connect or see it anywhere on my network.

i did like this:

http://community.wd.com/t5/My-Book-Live/GUIDE-Debrick-MyBookLive-v2-0/td-p/567582

From (16 

Thanks for all the help so far :slight_smile:

Same issue with 3TB. For me it is also not ok. Will try 2Tb this evening.

Success! 2T though, instead of 3, but finally dashboard is accessible, so ssh will…

Thanks!

i’m reading through this & great, … but …

got about 1tb of data on my 3tb mycloud drive i don’t want to loose :confused:

linux isn’t reading the drive at all

through windows recovery tools are reporting only 1 sector and can’t read anything

k, i care about my data (WD doesn’t)

got a second drive (online order) so this second drive should work properly right, … same as with the origeonal drive :frowning:

i would love to get my data back, … repartitioning or whatever else to start over scares me as i really don’t want to loose anything

any help ?

or something to help my confidence that i can recover my drive instead of reformat it

Hm difficult answer… If the drive can’t be recognized currently, you may be out of luck. That being said, I would expect dd could still at least try to read the raw drive and save it to an image. from that maybe you could find some tools online to recovery your files from the corrupt disk. if even dd is unable to save the drive though (through something like dd if=/dev/yourdrive of=/output/of/drive.img) then I would expect it’s a physical issue with the disk and the only way to get it would be through professional disk recovery services ($$).

Hello,

I’ll just describe my solution (just in case it will be useful to anyone).

Firstly, I’ve used SATA - USB convertor, so this way I’ve connected disk to my notebook.

dd command failed to me: it hanged for 6 hours without completion. while dd for 3Tb image worked flawlessly in minutes, but the firmware there was broken or not compatible to my disk.

So’ ive uploaded the firmware via Ubuntu disk utility as backup update and assembled drive back. It ran correctly w/o errors.

Secondary, I’ve made factory restore, so I was able to register users again and use SSH. Still there was a problem with diskspace of 2Tb instead of 3 physical terabytes.

Then I’v tried old-school unix fdsik utility to alter /dev/sda disk and resize or delete/create sda4 partition. Fdisk showed that it is not the best utility as GPT partition been used and recommended to use parted utility. Parted utility could be a solution here, but it showed that it cannot make changes to partition unless partiton is used by drive. Umount comand did not helped. Looks like there have been some autoreconnect scripts. So I’ve googled till gdisk utility, which actually equal to parted, but can work without dependency to used by OS partitions. So, it showed broken GPT partition table and I fixed it by using options ( r       recovery and transformation options (experts only), d use main GPT header (rebuilding backup)), then I’ve ran w and made a reboot. GPT fixes were needed due to the fact, that utility wasn’t able to use unalocated space before them, maximum amount was the same as for previous partition. Then I’ve deleted 4th partition and created a new one with extended diskspace. Then again w and reboot.

After reboot it was still shown 2Tb in dashboard, so I’ve made yet another factory restore and ran first configuration utility. Next setp - I’ve loaded firmware update from 14.06.2014 and still using it flawlessly.

Jevgenijs

Just to add: 

gdisk should be installed with “apt-get install gdisk”

Thanks for the info djh816. I followed the instructions but I just get a solid white light (it seems to blink once every 30-45 seconds).  I originally started on this procedure after a botched crashplan/java install (I was on v4 of the WD firmware). I was attempting to restart the device via ssh and when the device came back online I was unable to SSH or access the dashboard (though I was still able to view the fileshare). SSH gave me a connection refused. After the restore, the device isn’t recognized by SSH, dashboard or fileshare. Any ideas where to go from here?

I was able to restore my MyCloud! Thanks to everyone here for their instructions!

If anyone is having issues, you can try the following.

  1. Make sure you are using the right disk image! I was using for my 2TB drive:

https://mega.co.nz/#!PElwgSyJ!Aicrq1FKKojLVjJgBAz37Sa-9F1KaPeeyMhZ3lN2vpg

  1. Make sure that that the extracted mycloud2tb.img file is 5.24 GB in size. 

MD5 (mycloud2tb.img) = 1172e8a5c0157c820a3c089006f12992

  1. Ensure your flash drive can support large files. I used an old flash drive with FAT32 to transfer the file. THIS WILL NOT WORK because the FAT32 system has a 4GB limit. Unfortunately, my Mac didn’t warn me when copying the file and just truncated it. Reformatting my flash drive to NTFS was required. (I used  http://www.paragon-software.com/home/ntfs-mac/ 10-day trial to get NTFS support on my mac)

4). I’m sure that once all of the above works, you can just copy the files using the dd command within any linux liveCD. However, I booted up UbuntuLive from a CD and used the Disks utility to write the img file to disk. I chose this route because although I was able to write the image to the drive using dd, I was getting strange output from umount. Umount would say “unable to umount /dev/sda device is busy”. However, listing the mount points didn’t show anything.

If you use Ubuntu, I think the OS will automatically mount the swap partition on the drive. So if you try and write the image using the disks command, you will get a similar device in use error (i can’t remember the exact error). I think Ubuntu automatically utilizes the swap partition on the drive, so before you write the disk image, besure to right click on the swap partition on your mybook drive, and select “Swapoff”. Once you do this, just select the gear icon in the upper right of the disk utility and choose restore image, and choose your .img file. 

After all of this I got a blue light! Thank you to everyone in the forums for posting their experience and advice.

1 Like

Congrats on the fix Ryan. Sorry I didn’t get a chance to reply until now, swamped with my own IT work :stuck_out_tongue: I never ran into that issue because I was using NTFS usb stick from the beginning but that’s a good catch, I’ll mention that FAT32 is not a good format in the OP. Thanks for the info and report back on success :slight_smile:

For anyone wondering, there /shouldn’t/ be any software difference between the software handling the 2TB, 3TB and 4TB disks, and it should be possible to restore a broken disk from any image. In case that your partition layout hasn’t been changed, it is sufficient to use the kpartx linux tool to mount the image of your choice, and restore partition by partition. For those willing to retain their data partition, just avoid to restore sd*4, but just do sd*1 and sd*2 (which contains the firmware), sd*5 and sd*6 (which contains the kernel) and sd*7 and sd*8 (which contains the configuration). sd*3 is swap space, so it doesn’t need to be restored.

do you have a link alternative for the mycloud 4 terabyte

1 Like

why are people restoring the whole image of the drive for bricked deivces? or have you all managed to screw up your partiton tables?

I’ve bricked mine 4times now. Most recently this week and have always just restored by copying the roots.img file over the 2 raid partitions, retaining everything.

Hi, everyone!

I`ve got a 3 Tb version of MyCloud, with latest firmware 4+

I tried to install Transmision via SSH (Terminal, Mac OS X).

In progress of installation, I saw, what some of packages were lost and installation was not complete.

After that I lost a connection with USB port in MyCloud. In UI were an error, what usb server have problems.

I`ve tried to reboot my device via UI and where is another problem - MyCloud UI wrote that the reboot is not possible.

After that, I have a connection to my files, but when I am trying to get UI, I see a message - reading system information…and nothing more.

Access via SSH is not impossible, where is access denied. So now I don`t know how I can fix this issue and get back my device in good working condition.

In fact, I don`t have a brick. I have access via SMB. Problems with my Debian part (or UI)

Guys, anyone have an ideas?

I don`t want to open plastic case, maybe I can directly connect MyCloud in my PC and update a firmware?

Greetings AAleksey.s,

Can you restore the firmware using the reset button on the back? That should let you restore the entire stock set of software, assuming that image is still in tact. I believe the procedure was to power it off, then hold that reset button as you plug it in and power on. If that fails, and all you have is SMB access, I would say without SSH the procedure mentioned in the original post would be the next step (or you might just want to try talking to Western Digital for a replacement if you just used their WebUI and no SSH). Point being if you JUST have access to SMB, all that would let you do is copy and retrieve files to that specific share’s folder. I don’t think there would be a way to execute a file period.