GSpeed Q Drive will not turn on

#1

Last night the drive worked fine but this morning it would not turn on. No lights, fans, nothing. I tried switching the FireWire 800 cable but it didn’t help. I need the data from the drives! Help!

#2

Did you check the power cord? They are generic cords so if you have extra you can swap them. Same type of power cords for older monitors, PCs etc.

#3

Thank you, I did switch out the power cord after you suggested it. I also tried moving the system to a different wall outlet, and changing the firewire cable. The fan twirls around once and stops when I try to turn it on. The fan looks quite dusty, might that be a cause? I could try opening it and cleaning it out if that could be it, but at this point I am wondering what my options are for data recovery and to have the drive repaired. I am hoping to restore the data as soon as possible, the drive not so urgently needed. Should I do that locally, or would it be necessary to send it in to g-tech? I am figuring it is not under warrantee anymore as it was purchased in 2010. Thanks again.