G-Speed Shuttle SSD / macOS Monterey / Apple Silicon M1 Max

No further response. I have contacted Apple support. No knowledge of this issue and no recognition that it is being worked on. I have former colleagues who still work at Apple (I recently left WWPM there after many years as a PM) who are aware of the issue but claim these are known issues that 3rd party developers who rely on kExts were warned about almost 2 years ago as a looming and required change. My hopes of a magical update coming from Apple soon is waning. 64TB of data made useless.

This is an update, thanks to @Alright4here post I was able to workaround my problem and get a fix for my G-Studio XL 12TB, follow his steps on this topic.


1 Like

So I’ve used the Promise drivers and managed to get my drives to show up for a few hours to minutes each. Usually they end up un-mounting themselves, sometimes they just lock up the Mac. One of them no longer mounts at all.

I’d like Western digital to send me a pair of 32TB SSDs formatted in exFat (their suggestion) so I can attempt to copy my information off these dodgy drives. Otherwise I’d like a complete refund. This nonsense has gone on long enough. Close $20K worth of drives that are completely useless.

I’ve contacted Apple support and former colleagues there (I just left Apple last year after 26 years in product management) and neither set of folks are aware of a pending fix coming from Apple.

I have no functional driver from Western Digital, no functioning Drive Utility, and no path to making these things useful.

I’d like a response from Western Digital.

Hey everyone. I’m currently in the process of switching over to mac from Windows, the m1 lured me in.

I was going to get the g shuttle to use for external storage, I’m a photographer and DOP, but am a little worried having seen this thread. Having looked into it more it seems like there’s lots of issues with RAID systems on m1.

Have you guys managed to solve this issue with the shuttle? Any advice would be great and sorry you’ve all had to go through this. Must be very frustrating!

I’ve owned 9 RAID arrays based on the Promise technology (the G-Tech drives are essentially repackaged promise RAIDS, easily verified by taking them apart when they fail).

4 of the 7 Promise drives failed. Usually first a drive module and then eventually the backplane. I have owned many G-Tech drives and they have never failed me, which is what drew me to the G-Tech 32TB SSD RAID. Speed, massive storage, and G-Tech reliability.

I had failed to pay attention to the fact that Western Digital had purchased G-Tech.The company that once provided amazing quality and support and wore their love of the Mac on their collective shirtsleeves is gone. Customers running macOS probably represent a very small percentage of their business and clearly the Mac community is not a priority for their team. The rebranded Drive Utility is something of a train wreck. A small but telling example: if you Mac is set to move automatically from Light to Dark mode while the utility is running, the UI essentially disappears. Nice. The Promise team probably finished primary development of that core code years before Light/Dark modes were and thing and no one has bothered to touch it. This is very telling. Even the company they are tacking the software from and rebranding it doesn’t care about the Mac.

I purchased 2 of the 32TB SSD RAIDS. I was saddened to see the same clunky drive utility software repackaged from Promise, but the drives worked flawlessly and delivered great speed.

A few months later I moved to Apple Silicon and ran into trouble. WD was not prepared for the M1 (that’s fair) and even though drive manufacturers had been warned for well over a year by Apple that kExts were not the future, their Promise software needed some coaxing to work.

No worries, the community figured it out before WD did and things were fine. Then Monterey shipped and everything went sideways.

Some folks have managed to download the Promise driver direct from Promise and get their drives working. After paving my Mac twice and working through the promise directions I managed to get the drives to mount. The throughput was greatly reduced, and usually any long-running file operations would fail and the drives would unmount.

Finally last week one of the two drives failed, reporting 4 of the 4TB SSD modules as dead. Data loss, drive dead.

I have little faith that WD will replace this drive (it is 9 months old) nor do I expect much of a change in their support.

Since Monterey shipped, many of us have been reporting issues. First we heard that they were working on it, then we heard Apple was working on it, then we were told to format the drives as ExFat (difficult if it won’t mount and is full with critical data), and now silence.

I worked at Apple for 26 years (just recently went to another company). During my tenure I had the privilege of being the product manager for the iMac, the Mac Pro, several models of MacBook Pros, and many other models of hardware. I knew G-Tech to be a great Apple partner. I trusted them.

I have been told things my WD support that I know to be false (I know the folks at Apple responsible for the Apple side of these issues). I don’t hold the individual support reps at fault. I imagine they are being told what to say and don’t know the truth.

The especially sad part though, is that I will probably have to buy another one of these shoddy drives - there are not many other offerings and I don’t have the time and energy to DIY on a RAID system.

My advice: if you go with any WD product for critical storage - buy two or three of the same device, same capacity. Open and format all three. Put one into your workflow, backup to the second one, and keep the third one handy as a replacement. The promise stack has proven to be unreliable. One is none, two is one, three is convenience and peace of mind.

I could only afford 2 of the 32TB SSD drives and now I am in a tight spot.

Good luck.

Thanks so much for that response.

It seems pretty ludicrous that this has happened. I’ve spoken with Apple tech and they said that there are no RAID systems which they can currently confirm compatibility with the m1 chip and monterey. That’s crazy!

Anyway, I’m still a little unsure of what to do. The apple tech said normal, single drive, external storage devices will work but that’s no a solution for me. I asked them to get back to me in a month, it’s a while before the laptop comes, and let me know if things have changed.

Worst case, I’ve got a large 24tb drive which I can use as backup and then maybe risk getting the g shuttle 24tb and hope for the best…sounds mental even suggesting that as an option…

This is unreal! I just got 2 new M1 Pro and M1 Max laptops & M1 Mac Mini with 10GB Ethernet and was intented to share G-Tech Shuttle XL 70TB drive for new laptops. Hey Apple, what are you doing there!?! I have spent too much money for nothing!

Have you found you can’t connect to the shuttle? I thought there was a “fix” on WD website.

1 Like

Really!? I found this one: SanDisk G-RAID Driver on M1 Mac Installation Guide
Sounds promising, let´s see if it really works.

That may be the one. I think I found it through the faq on their site. I’m not sure if it works though.

If you don’t mind, let me know how it goes for you. I’m still waiting for my m1 to arrive and need to decide what I’m doing for external storage

I have been using the Promise drivers since the first M1 models shipped.
Sometimes the drives mount quickly, sometimes it takes 20-30 minutes to mount, and frequently the drives refuse to mount. This is not a “fix”. Western Digital needs to fix this, not Apple. Apple provided third parties clear instructions on how to deal with this two years ago.

1 Like

Ah OK. So not a fix at all! 20-30 minutes to mount is crazy. Hopefully they sort this soon!!

I have one iMac Pro and it works with G-Tech Shuttle XL like a charm. Maybe I should share the G-Tech drive with iMac Pro and its 10GB Ethernet. It just sounds grazy to use a 18 core Xeon workstation for this kind of job…

This issue is really making me doubt the whole m1 max purchase…I’m wondering if I’d be better off just sticking with a PC. I would have thought this issue would be sorted by now since those computers have been out for quite some time

I really hope that this bug is going to be fixed very soon. After using one week my new M1 Max MBP it just rocks! I have edited 4K video (DJI Phantom 4, Canon C70 and Canon 1D X Mk3) and made some heavy Lightroom & Photoshop tasks and it just keep up the speed! Fortunately I have 8TB SSD in my MBP and I can do my job without external drives for a while.

Sounds good. Honestly my pc was really good and could handle most tasks. It fell apart a little with footage above 4k and with GPUs being so expensive these days, plus a few advantages of having a very powerful laptop, the switch made sense. This external HDD issue is quite a concern though, surely they must fix it soon…some owc products are advertised as working on m1 but I’m not sure if I trust them, not sure why I don’t just don’t know the brand

You can trust OWC, it is one of the most Mac friendly brands out there. Just don´t buy or trust a softraid (IMHO). And like you said, the new M1 Max is as fast on the plane than at the office plugged to power outlet. That makes it unique! :ok_hand:t2:

That’s good to know. I’ve heard/read that a hardware raid is better than software raid. That’s one of the reasons I saw the G shuttle as being good.

I looked on OWC’s website and they all mention Softraid. Do any of them support a hardware raid? Apologies if I’m being a little stupid here this is all new to me.

Following this too as I have two 24TB drives that currently can’t be used… how frustrating!

I spoke to a tech adviser at G-technology yesterday and he said he’s dealt with a few people who did have issues but that it all seems to be sorted now…this obviously leaves me a little confused about what’s going on given all your experience.

This is an extract from a follow up email he sent to me:

"As we discussed during our call, there should be no issue connecting the G-Raid Shuttle 4 and having it recognized. However, the first step will be to install the M1 TB 3 driver. This is available from the link below. In the link you will also find a Utility available, which is a dashboard for the G-Raid Shuttle. I would recommend also installing this software. This will give insight on the Raid status and would also be required in case you want to change or rebuild the Raid.

Essentially, he said with this stuff installed it should be fine. I’m not sure if he was only talking about the newer TB3 devices though and not the older TB2 ones.

What model shuttles do you guys have?

1 Like