G SPEED esPRO running slow

I have a esPRO 12TB RAID 5 connected to a ATTO express SAS R680 driver version 3.7.5 inside a Sonnet Echo express SE II connected to a MacPro. I also have a Pegasus R4 Thunderbolt 2 12TB RAID attached to the MacPro. I use to get the same disk read/write speeds of approximately 480 MB/Sec on both drives. Now the G-Speed is only getting 250MB/Sec. We had sent the ATTO card out to ATTO for testing and they said the card is functioning properly. We replaced the drives in he G-SPEED and that hasn’t changed anything. What else could cause this sudden dip in performance?


It could be related to the miniSAS cables. Have you changed them out at all? One thing you can try is to swap the ends. Plug the part that is going into the card, into the drive and vice versa and see if you get different results.

Also have you tried both of the ports on the eS PRO as well?

Thanks for the reply. The cable is relatively new and was swapped out at one point. I tried reversing it as well changing ports on the ATTO card. I got the same results.


Based on the trouble shooting you have completed and the fact that the speeds are roughly half of what you used to get. I would suggest checking available space on the G-Speed or possibly the Echo express SE II may be malfunctioning and only providing half the throughput.

Well like I stated the card was sen to ATO and they tested it and concluded it is functioning properly. There is 4.66 TB available on the drive. Again its a 12TB RAID 5 configuration.

OK so I swapped the Sonnet box with another one and got the same results. I also tried a different Thunderbolt cable and got the same results. We replaced everything possible between the machine and the Sonnet.