G-RAID not mounting

My G-RAID fails to mount. I tried on 2 different computers without success. I use a Mac. I also used different power supplies.

  • Disk Utility does not recognize it.
  • Disk Warrior 5 fails every time I try to rebuild the drive, it even causes a Kernel panic and my computer shuts down.
  • TechTool 9 gives me a “fail” when I try to use “Volume Rebuild”

Any suggestions how to fix it?

Thank you!


If Disk Utility doesn’t recognize it at all, even the physical device then Disk Warrior and TechTool would not be able to see it as well.

If it can’t be rebuilt and it is causing issues with the system have you tried attaching it over another interface? How long have you had the drive? If it is under warranty it can be sent in for replacement under warranty.


Disk Utility does not recognize it but Disk Warrior and TechTool actually do. Not sure what you mean by attaching it to another interface. You mean a different computer? I already tried on two macs. Should I try on a PC, I suspect it is formatted for mac so not sure if a PC will read it.
I’ve had the drive for a couple years now and it’s not covered by warranty anymore. Instead of getting it replaced I really need to access the information on that drive as it’s very valuable to me so any advice on how to get the drive to work?

Thank you!