G-Raid 4TB unavailable / front logo flashing white

My G-Raid 4TB drive is suddenly unavailable (Won’t mount on Mac. Tried two). Mac Disk utility sees the drive but unable to run first aid. I’ve tried turning off and back on. Hear drives spinning up, then front logo starts flashing white. I checked the power adaptor and notice that the light on the power adaptor isn’t lighting up, not sure if that is any indication or if it’s a controller issue in the enclosure? If so can I replace the enclosure to access the data on the drives?

UPDATE: When drive is plugged in WITHOUT being connected to Mac and turned on front logo light turns on solid white, drives spin up. Then spin down. Light stays on solid while. Plug in firewire cable and the drives spin up again and stay spinning, white light starts flashing non-stop. I can hear drives moving as if they are working, then the white light stops. Unable to mount drive. Get "Cloud not mount… (com.apple.DiskManagement.disenter error 0.), then white light below logo starts flashing non-stop again.

Screen Shot 2020-01-12 at 8.39.26 PM

Thank you!!