G Drive not seen on Macbook

Have high end MacBook and use 2 TB G Drive with usb to back up with time machine. Plugged in to back up today and MacBook doesn’t see it at all and the G Drive just runs and runs and runs with the light blinking in front and you can feel the drive is constantly running. Disk utility doesn’t see it at all. Rebooted many times with same results. Coming to the conclusion this back up drive is toast. Anyone have any other ideas?

I’m having the exact same problem with a 1 TB G Drive. It was working fine until Saturday, July 30, '16 when suddenly it wouldn’t connect any longer. The drive was spinning, but doesn’t show up on my Mac.

Phil,

Does your drive ever stop blinking? The LED blinking constantly is a sign that the system isn’t able to recognize the drive in the enclosure. Do you happen to have any other USB cables you can try or have you tried any other ports on your machine?

If you have tried those and still get the same results it would likely be a hardware issue either in the drive or the enclosure. I would suggest contacting our phone support so we can check warranty options for you.

Toll free (888) 426-5214

My light doesn’t stop blinking.
I went to Best Buy and had them use a new cable to hook me up to a new Mac and nothing happened.

Heidi,

Your issue looks to be quite similar. The enclosure could be at fault if you are both still hearing the drive spinning inside and they aren’t making clicking noises they are likely fine.

Make sure you both double check your power adapters to make sure they are 12v 2a output. If your drive is out of warranty You can check here to see if it is. I would suggest calling in for further support as well Heidi.

Rydia,

I don’t have a power adapter.
The drive was making clicking noises last week.
It is not within its warranty, but I still need the information on the drive. What do I do?

OK so you are using a portable drive then. If it is making clicking noises that usually means a hardware failure in the drive mechanism. When that happens we can only recommend a data recovery company at that point unfortunately. Data Recovery

I just got off the phone with your people at the 888 number and they gave me a number (which I read back to them and was confirmed) that I was told to call to have my drive trouble shot. When I called the number – 401-392-1000 – it was a completely unrelated company and the guy who answered had no idea what I was talking about.

When I first plugged it in - time machine started a backup. After running for awhile, I received a series of about 12 alerts/errors saying the drive should be ejected properly next time. After that, just LED blinking constantly after a lot of reboots, power down and wait 5 minutes, using different USB port, trying anything to see if the disk utility could see it. I don’t have clicking sounds just can feel the drive spinning and searching.

I left mine plugged in and it suddenly began working again. I immediately ripped open my new drive and began transferring files. Who knows when I’ll lose it again?

My G-drive mobile USB seems to be having an identical problem to what Heidi described. I am within warranty, I only purchased it two months ago, but I recently moved, and I don’t think I have my paperwork for the device anymore. I cannot believe it’s broken so quickly after buying, when I bought because I was having problems with my computer’s harddrive in the first place, and was worried about losing my writing. :frowning:

I am also having this problem. My MacBook Pro just stopped recognizing the g-drive. I was finally able to get it to show up in disk utility and did first aid and started a time machine backup, but I had to restart my computer several times for other issues and now it won’t show up again. The white light just flashes non stop. Did anyone ever find a solution?