FTP writes stop working every few days

Ever since Mycloud PR4100 firmware went to 5.22.113, FTP works as it should (I have several cameras each writing many hundreds of files every day). However, after around 3 days, file lengths become zero - and a few hours later the process fails completely - and if left that way, certain IPs get blacklisted, necessitating an FTP config cycle to free them up.

I have been using MyCloud for years in this way, LAN only, hitherto without problem. It smacks of a stack size reduction or a memory hole. No error messages result, and either a MyCloud reboot or an FTP services stop/restart restores normal operation - for a few days then same problem.

Anyone else have this issue? Anyone managed to down-issue firmware to 5.21.104 to restore a working FTP system?

Hi @RogerJP,

Please refer to the article My Cloud: Configure FTP Server Access:

If further assistance is needed, please open a case with our support team at the following:

Hello Keerti_01 and thank you for responding.

FTP configuration is not at issue. The system has been working - correctly configured - for years.

Two cases are open, but, no solutions are yet forthcoming. I have complied with each request from the service call staff member, and I hope this aids diagnosis. However, whist I am busy helping WD diagnose the issue, I am frustrated by intermittent performance. I need to be able to rewind the firmware one stage to the last known stable release - but the file provided - even when unpacked - gives me “failed” when I try to do so.

I am reaching the point where I may have to buy a new shell and migrate.

I fear end customers are not a lot more than glorified beta testers these days. That scenario was once the preserve of Micro$oft, but the same brush seems to be tarring more and more companies.

The 5.21.104 firmware for the PR4100 can be found at the following WD link:

Note however that the WD firmware itself may try and prevent the user from rolling back the firmware to an earlier version. If this is the case one may have to use the forum search feature (magnifying glass icon top right) to see if anyone has successfully rolled back the firmware on an OS5 My Cloud to an earlier OS5 version. Of course rolling back the firmware does open the My Cloud device to any security vulnerabilities or services that were closed/patched/updated in later firmware versions.

Another option that may be a less than optimal or less than elegant workaround (if one hasn’t tried it already) is to setup a scheduled device reboot every two or three days to see if that can bypass the FTP issue.

My Cloud: Configuring the Power Schedule

1 Like

Bennor - many thanks for your suggestions - and you may have just saved the day!

I tried the firmware rewind a few days ago - the first service call sent me a link to an enormous download (I mean enormous - a 2.3GB .gz file which unpacked to a 2.4GB .tar file, which in turn unpacked to 7 subdirectories. Trying to rewind to either the .gz or the .tar file failed. However, the .bin file you linked to worked like a charm. In three days time I will know if it’s been successful.

I’ve turned off auto-updates too!

The idea of power play is good - but with the user interface I’d have to be off for a 2-hour period. If the software rewind had not been available, my next move was actually going to be an even cruder and harsher method - a smart socket that powered down for just two minutes a day.

I reckon the rewind will do the trick. I wonder why the service desk sent me the link to such an enormous download?

Thanks again - so very helpful.

After 8 days I can confirm that all is well, and the unwinding of firmware has indeed restored normal operation. Thanks again.