Ftp problem with passive mode

I want to access my book live duo from outside.

I have dynamic dns, open port 20 and 21 and 5000 to 5099.

If i make a test with http://ftptest.net I take this:

Status: Resolving address of ******.dtdns.net
Status: Connecting to 89.210.72.***
Status: Connected, waiting for welcome message
Reply: 220 “Welcome to MyBookLive”
Command: CLNT http://ftptest.net on behalf of 89.210.72.***
Reply: 530 Please login with USER and PASS.
Command: USER admin
Reply: 331 Please specify the password.
Command: PASS ***********
Reply: 230 Login successful.
Command: SYST
Reply: 215 UNIX Type: L8
Command: FEAT
Reply: 211-Features:
Reply: EPRT
Reply: EPSV
Reply: MDTM
Reply: PASV
Reply: SIZE
Reply: TVFS
Reply: UTF8
Reply: 211 End
Command: PWD
Reply: 257 “/”
Status: Current path is /
Command: TYPE I
Reply: 200 Switching to Binary mode.
Command: PASV
Reply: 227 Entering Passive Mode (192,168,1,10,19,230).
Error: Server returned unroutable private IP address in PASV reply

What I am doing wrong?


Have you been able to test FTP access within your local network using an FTP client? Are you able to access other FTP-enabled devices on your home network using the same method?

1 Like

Looks like your router doesn’t support Passive FTP ALG – (“Application Layer Gateway”) so it’s not translating that PASV instruction to use your outside address.

Some routers do, some don’t – and finding documentation on which do and which don’t is darn near impossible.


Only option I know of for you is to modify the FTP configuration in the Duo to specify your outside address…  and that’s got its own problems if your outside address changes…

1 Like

The FTP works fine when I am at the local network. The strange thing is that before I had a WD Mybook World Edition 2 and the FTP worked ok when I was outside with the same router (Thomson TG585 v8).

Ok, I found the solution. I added the line



and now it works like a charm!

***.dtdns.net is my host name on dtdns.net

Thank you for your support. The strange is that with mybook world edition 2 worked without this line