FTP Access issues stuck connecting

I have setup my FTP and everything correctly.  following the steps at  http://wdc.custhelp.com/app/answers/detail/a_id/2680/~/how-to-access-data-using-ftp-on-a-wd-personal-cloud-drive-and-other-wd-nas

However whenever I try to connect to it, it just gets stuck attempting to connect.  No rejection, or connection rejection, or password incorrect message nothing.  ANd i’m just trying to connect to it locally over the same network

Any suggestions?

Welcome to the Community.

Just for testing purposes, what happens when you try co access it from a remote connection?

I seem to be able to connect to it fine using my NOTE 3 using ES FILE MANAGER using Active Mode.

However I can’t seem to connect to it while I’m local  This is all that happens (using ACE FTP 3 DEFAULT SETTINGS)

220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
220-You are user number 2 of 10 allowed.
220-Local time is now 15:42. Server port: 2121.
220-IPv6 connections are also welcome on this server.
220 You will be disconnected after 10 minutes of inactivity.
USER admin
331 User admin OK. Password required
PASS *****
230 OK. Current restricted directory is /
215 UNIX Type: L8
Server Type: UNIX (standard)
211-Extensions supported:
MLST type*;size*;sizd*;modify*;UNIX.mode*;UNIX.uid*;UNIX.gid*;unique*;
211 End.
257 “/” is your current location
200 TYPE is now ASCII
227 Entering Passive Mode (104,4,41,2,217,48)

And thats it… stays on LIST then it like freezes it up or something cause if i try to connect after that it just stays trying to connect then times out until after a few minutes then does the above again

Yea using the exact same FTP Client (ACE FTP) i can connect to it using my laptop from outside of the network.  Very very weird.  ANy ideas why this is happening?  I can access the website itself to change the settings to the MyCloudEx2 but thats it

This is happening because the EX2’s ftp server settings have a limitation…if in ftp configuration from the dashboard you enable the “Report external IP in PASV mode” checkbox (and you currently do have it enabled), then you’ll be able to connect fine from outside but you cannot connect to the ftp server from inside using internal IP. On the other hand, if you disable (uncheck) that checkbox, your ftp connections will work fine inside the network but you won’t be able to connect from outside. This is because once you enable that setting, and are connecting from outside using a passive connection, the ftp server tells the client after initial connection on port 21 to make the subsequent data connection at the specified external IP address (specified in that ftp setting) and at a certain port that the server randomly picks from a range of port numbers (that range is also specified on that setting screen). Because that external IP is not valid in your local (internal) network, the client is unable to find that IP and therefore unable to make the data connection after the initial login connection…so it hangs.

So, the only and simple way to get around this issue is to simply leave that setting enabled so you can connect from outside, but while you are inside just connect to your ftp server NOT using the internal IP but using the external IP. This causes the client to make a connection from outside. Then, just like clients that are connecting from outside, this connection too is able to make the data connection. For a more in depth understanding google for active vs passive connection, and then read up on how two-stage passive ftp connections work (basically first a control connection is made by the client on port 21 and then a data connection is made by the client to whatever IP and port the ftp server tells the client to make the data connection on).

Other ftp servers like Filezilla ftp server has settings to detect when a connection is being made internally and for those connections it does not send the external IP but instead sends the internal IP to the client. The ftp server in the EX2 unfortunately doesn’t have that capability, so you’re always forced to pick between either external connection working or internal connection working, but never both simultaneously.

If this helps you, please click the star on the left under my username to give me a kudo. Also, mark my post as the solution, so that others can benefit from this in future.