FTP access doesn't work


#1

I can’t get my FTP to work. I have another NAS (LaCie) which I can access by ftp. I also have a HDX-1000 NMT which I also can reach by ftp without any problem. I can’t, however, access the WD Sharespace by ftp. This leads me to think that it’s not my routers (D-Link DIR-635) fault since all my other devices that are reachable by ftp works fine.

  • The port is forwarded in my router to my computer and I have tested this withPFPortChecker.
  • I use Filezilla as ftp client.
  • I have tested this on both Win XP and Win 7 running computers with the same bad result. :cry:

What am I doing wrong? Any help would be very much appretiated.  


#2

Here’s the log from Filezilla if it’s any help:

Status:    Connecting to 192.168.0.110:21…
Status:    Connection established, waiting for welcome message…
Response:    220 vsFTPd 2.0.4+ (ext.3) ready…
Command:    USER mossarp
Response:    331 Please specify the password.
Command:    PASS *******
Response:    230 Login successful.
Command:    SYST
Response:    215 UNIX Type: L8
Command:    FEAT
Response:    211-Features:
Response:     EPRT
Response:     EPSV
Response:     MDTM
Response:     PASV
Response:     UTF8
Response:     REST STREAM
Response:     SIZE
Response:     TVFS
Response:    211 End
Command:    OPTS UTF8 ON
Response:    200 UTF8 option is On.
Status:    Connected
Status:    Retrieving directory listing…
Command:    PWD
Response:    257 “/”
Command:    TYPE I
Response:    200 Switching to Binary mode.
Command:    PASV
Response:    227 Entering Passive Mode (82,145,151,86,19,159)
Command:    LIST
Response:    425 Failed to establish connection.
Error:    Failed to retrieve directory listing


#3

hhhmphhh…u probably did this already, but can u please specify the permissions of user mossarp on the directory which you enabled FTP?


#4

How have you define the user + password ?

I have a WD TV LIVE + Passport 1To and I can’t access my passport with FileZilla :’(


#5

Mybook world does not work with Passive mode for FTP,  Choose Active mode instead for Filezilla  and you can change it under transfer setting.

If using bulletproof , it should be ok.