Former NAS drive not recognized in PC

I was given a NAS when an office was closed down. I didn’t need another NAS in my environment but imagine my joy when I opened it to discover a 4TB WD Red drive. Just what I needed for the QNAP NAS I wanted to build. I removed the drive and disposed of the NAS it was in and thinking there was a linux partition I attached it via USB to my linux box so I could wipe it as I have no interest in the data on the drive. However the logs show I attached something but it never finishes being recognized. I tried moving it to my Win 10 box and the IntelMatrix Storage Manager RAID controller sees I have attached the drive but is displaying “Locked Disk”. I have tried running SpinRite on it but it will not recognize it either. Because the OS does not see it Data Lifeguard Diagnostic does not pick it up.

As I said, I am not interested in any of the data on the drive so if I need to low-level the thing I am fine with that but I cannot get anything to really “see” it. The date on the drive is 2017 so its practically brand new and the guy at the office said it had been running fine. What are my options here? I have 2 4TB Reds and I only need this one last one to get my RAID5 going.

For what its worth, the drive is recognized in the BIOS as WDC WD40EFRX-68N S/N WD-WCC7K7DYT7PC

Serial number indicates the drive was shucked from a My Book, which probably has nothing to do with the issue. :slight_smile:

Anyway, sometimes even if a drive does not appear in Windows, it still appears in the Disk Management console. If it’s there, you can try initializing the drive (which would destroy the data in the drive but since you’re not interested in it, that’s fine).

Chances are that if it came from a NAS, the format is EXT3 or EXT4 which is a linux format.

You can get drivers for that format for Windows (I think Macs support it natively, but not sure.)

Or, if nothing else, you can boot your PC using just about any Linux Live Distro which will be able to read the files.

Yeah, that’s the rub, The drive does not show up in Disk Management under Windows. I have tried connecting it to my Linux laptop via USB but the kernel is unable to “process” it. It sees that something was attached but it never comes back with anything and it does not appear in the “Disks” utility.

I just took a Red 3TB out of my old MyBOOKLIVE and installed it into my Zyxel NAS520. I connected it to a Windows 10 box via USB 3 before I installed it in the Zyxel. I used the free Minidisk partition tool to just remove all partitions. Then I put it in the NAS and let it do the rest.

Just sayin…so you know it has been done :slight_smile:

Instead of connecting the drive via USB, I decided to put it in my Windows box and use a live CD of linux. Using hdparm I am able to see these values under the security section:

Security: 
	Master password revision code = 48059
		supported
		enabled
		locked
	not	frozen
	not	expired: security count
		supported: enhanced erase
	Security level maximum
	482min for SECURITY ERASE UNIT. 2min for ENHANCED SECURITY ERASE UNIT.

I tried to perform a --security-erase using the “WDC…” password but I got this error:

/dev/sda:
 Issuing SECURITY_ERASE command, password="", user=master
SG_IO: bad/missing sense data, sb[]:  70 00 05 00 00 00 00 0a 04 51 40 01 21 04 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

Does that give anyone any ideas? I am seeing several sites where the moderator will not even touch the subject for security reasons, and I can totally respect that, but shouldn’t there be a way to just nuke the drive and start over?

Not sure if this will work as the security level is maximum.