Formating failed

I got a Computer with windows 10 and i needed to replace my disk cause it makes strange sounds. So i bougt a purple line wd 2tb disk and go to disk manager make partition and formated it. after that i got the windows error format failed. But i saw correct the disk in Windows but could not open it. I tried the same with slow formating. nothing. After that i used the windows console tool for disk formating but i aborted cause it was running way too long
So i downloaded the wd analysis tool and make a disk analysis. It was running forever. So i decided i got a bad disk…(amazon warehouse)
later bought a new disk (wd 2tb blue) go in disk manager formating and same error. Formating failed. I can see the device letter and everything but cannot acess the device.

What can it be?
I was thinking maybe Sata cable (I used a Sata2 cable i had somewhere)? More doesnt come to my head…

any suggestions?

Nobody suggestions it would be really helpful.

Try to connect it to a USB adapter on a working computer and see if it’ll partition and format. If it does might be the cable you used before or some BIOS setting might be incorrect for the SATA ports or try a different SATA port if others are available in the original computer.

1 Like

The Windows format utility’s test is worse than useless. It hasn’t been relevant since the MFM/RLL days.

The drive’s built in SMART tests are the only reliable way to test a modern drive. Unfortunately Windows’ SMART client is rather poor, so a 3rd party program is needed. CrystalDiskInfo is often recommended. If the extended test passes, then it isn’t the drive. It is normal for an extended test to take 7 to 8 hours with a large drive. Just let it run over night.

The SATA cable is a possibility. Is it seated properly? The ones with clips don’t always fit right. Do you have another you can swap it for? Try a different port on the motherboard. Try a different computer. Update drivers. Update BIOS.

Connecting using USB has its own problems, but is a possibility as well. Note that a drive formatted using USB might not work with SATA, or the other way around, since the reported sector size can change.

1 Like

Thanks for the answers. After some despair. i switched the Sata Cable and deinstalled every unnecesary software from the computer and suddenly everything fine.
I think some software blocked it. There was some strange disk protection software on the computer.

1 Like