Format a 2TB disk to correct file system for MC

Hi I need to format a 2TB disk so I can put it back in my cloud enclosure. I am not sure of the firle system I should use so that I can rebuild the partition table using parted. I have removed the drive and am connected to it by sata to USB.

I have had lots of problems with the my cloud and when it crashed I had to recover the data but due to a slip of the mouse the drive was formatted to NTFS. I need to reverty it to the format type it woudl have come with when I bought the drive. I realise I will need to do this in linus. Please can someone also give me clear instruction on how to rebuild the partions as am quite newish to linux. The problem I had using parted was it always gave an error saying drive was inuse ignore or continue but I think this is todo with the fact the disk need to be formatted to a certain file system. 

Q1 What file system should I format the hdd to at the moment it has no partitions and is just a 2TB blank ntfs drive.

Q2 What linux or unbuntu should I use to do this and to rebuild the partition table?

Q3 Can any one post a backup image of a 2TB mycloud as the ones previously posted have been removed if not I do have the 2gb rootfs image but the problem I had is that is was to big to be copied to the raid partition so if anyone could provide me with a simple solution to rebuild my 2TB icloud  from  what is now a blank NTFS drive  I would be very greateful.

Though if you can inly tell me how I format it back to WD MC file system that would be a start. TBH I dont really know what im doing but I am quite tech savy but linux is so new to me. I wish I could just boot from a cd and it would reflash the who drive for me and I would not have to do much.



1 Like

Hi thanks I have read that post and most others. I need to format the disk first to the correct file system dont I?. I have tried all of what that forum said it does not work. I have said above I dont understand linux enough and need a little help to do what that is asking.

Please can some one answer my questions posted above and tell me how I get the drive ready to do what that other post says. 

The links on the other thread have images files for the 2tb mycloud but they are all dead can someone post a working link to the 2tb image please. Do i even need to format the disk if I use an image?

Sorry for my ignorance and bad spelling.


I’d suggest fox_exe’s guide here:

The disk format you need is ext4. It’s mentioned in the third line of the thread I linked earlier. Admittedly, you’d have to know that ext4 is a disk format, and can accept partitions…

How to format a disk to ext4?

1 Like

Many thanks I have finally got it working again. It was not easy to be honest as I dont really know linux. it was the little things that were hard like coping the image file to the mmt directory.

Here are the issues I had:

mklabel gpt

 Said the drive was in use and I had to reboot this was using unbuntu it also kept saying the when I was using mkpart for the partitions

Stop auto-loaded raid: mdadm --stop /dev/md127

Said MD127 was not in use or a valid location so i changed it to /md0

10. Download one of arhive's to /mnt folder:

11. Extract by console:
tar xvfz original_v3.04.01-230.tar.gz

I had downloaded this already but trying to get this file to the mnt folder was problamatic as i have never used the cp command or had any idea about moving the file from the /dev/sdc2 to the /dev/sdc4/mnt…

For anyone else who is reading this these instruction do work and will rebuild you mycloud but if like me your not very good at using terminal shell then it can take a lot of trial and error. In the end I used gparted as my linux distro (if that is what you call them) The problem I found with it was that it did not have a gui file manager that would have made coping files quite simple. Though saying that when I used unbuntu it would not let me copy either as it said I was to the owner of the folder hence having to use the cp command.

I am now on verson 3.04.01-219 do you think I should stay on this version or update to the latest version of the firmware. one small thing it says that this is the latest firmware and when I check for updates it says it is already up to date though it is not. i could download the deb file but not sure if it is worth it or not/

Any way thanks for the link and to the person who wrote the below.

Many thanks I have finally got it working again


For anyone else who is reading this these instruction do work and will rebuild you mycloud but if like me your not very good at using terminal shell then it can take a lot of trial and error.

Yes, Unix uses a very compact, powerful and rather opaque command syntax, and it’s a steep learning curve, especially if you’re just trying to use it to do one task and come from a GUI background. Trial and error can be quite dangerous, though… If you’re familiar with unix commands, then those instructions should make sense, even though the formatting is inconsistent (i.e. commands sometimes on a clean line, sometimes embedded within a line, sometimes as a ‘short form’ hint for those who know what to do). If I ever needed to do it, I’d probably do some editing to make it a bit more consistent and clear (that’s not intended to be a criticism of fox_exe).

I am now on verson 3.04.01-219 do you think I should stay on this version or update to the latest version of the firmware

Well, that’s a tricky one… Some people delibrately stick to v3 firmware for a number of reasons (one being that it is possible to use the standard Debian repositories to install applications, and some feel that v3 is more stable. v4 uses a non-standard page size, so you cannot install standard Debian packages, hence the threads on packages built for v4 firmware. And now that WD are rolling out new remote access tools (‘OS3’), these will require the latest v4 firmware to use. v4 firmware also eliminates some known security issues for remote access, although there are other fixes to these… if you’re linux-savvy (installing updated packages to fix the holes).

Any way thanks […] to the person who wrote the below.

That’s fox_exe, I think.


I know this post is from quite some time ago, but I have a problem with my WD My Cloud and I would like to be helped.

My WD My Cloud (2Tb) has become slow and unstable. I tried to reboot it (reset 4 seconds and 40 seconds) and it stays the same. I have also tried deleting almost all user data and deleting the settings.

I would like to restart it, loading a new image to see if it works properly, or even change the disk for another if that is the cause.

But I have two problems.

I do not know if the new disk should be of that capacity (or it can be higher or lower), if it should be a wd red or it could be another wd or even any other disk.

The second problem is that the links to download the disk images to load the system again, are dropped or inaccessible and I can not download them. Does anyone share them with me again or tell me where to find them?

Thank you very much.

Hi I have the disk image to reset your 2 TB drive. It is very simple with the image but you obviously need to take the drive out of the enclosure and connect it to a computer.

It has been a while since I have done this but I remember is was quite simple compared to other methods of resetting the drive. The image will create the partitions for you so you don’t really need to do anything. I believe the hard drive size can be bigger (not sure about smaller) but you would need to shrink or expand the user data volume. I though think once you have re-imaged it it will work fine. Once the re-image is complete you will need to update the firmware to the latest version via the UI as this is version 3.x.x

The image file size is 5GB.
This image is for the 1st generation of MyClouds not sure it will work with 2nd gen, the ones that allowed the installation of apps from the UI?
You need to use a linux distro to reimage the drive though you might be able to do this from windows but I have no idea how?
I formatted the drive before I did this. Using this image will delete all user data so make sure you have a back up of your stuff as trying to recover files is a long and slow nightmare.

2 TB Disk Virgin Image MyCloud for Gen 1 (Full Image) Can be used with higher disk sizes but you will need to expand the user data volume. Image not modified in anyway, stock firmware.
Here is the link:

Hi. Thanks for the job.

The disk already have it out and I only need the image to follow the indications of other post and see if I can get my disk back to work correctly.

How can I know if it is first or second generation?

My P / N is: WDBCTL0020HWT-00

Thanks a lot.

Regards, Hector.

-00 shows it’s a Gen1


Thanks a lot.


Let us know how you get on.


Of course. I suppose this weekend I can put with it.

I’ll tell you how it goes.

Thank you very much for the guidelines.

Regards, Héctor.


I took a while to try it today.

When I try to follow the steps to restore the image, it tells me that the disk is 2 Tb smaller than the image and gives me problems.

The image is 5.2 Tb while the disc is 2 Tb.

How do I fix it?

Thank you.

I finally ignored the warning and restored the image.

For the first time in weeks the my ui interface of my cloud has loaded in a few seconds (before it did not fully load and took tens of minutes). Thanks, thanks, thanks…

How can I check if the disk has problems? (The drive smart status diagnosis gives ok, but can I test it in any other way?)

Which firmware version do you recommend I upgrade? (I’m in v03.04.01-230, and I can update to 04.05.00-315. I do not have very clear explanation of the advantages / disadvantages of moving to the v4 (cpt_paranoia). I also think that my problems could have been by upgrading to v4)

Thank you.

Regards, Hector.

Well done. I’m not sure what those warnings are about but it might just have been your disk was ever so slightly bigger or smaller than mine from when I created the image?. This will make no difference as it does not matter what size the user data partition is. The other system partitions are small and standard. If your drive has booted everything checks ok it sounds all good :slight_smile:

The image is 5GB not TB :slight_smile:

I personally would upgrade to the latest version of the firmware to get the latest security updates and stability.

Keep the image file safe in case you ever need it again. Check you storage capacity is what is was before as if not you might need to expand that partition but this should not be needed from what you have said.

Take care

It is generally recommended to update to the latest firmware version. Certain features, like remote access, may not work (at all) in earlier firmware versions. Certain security holes are patched with later firmware versions as well.

Hi, thank you very much for the answers and for being so quick.

When restarurar the image is when it says to me that it will occupy 5 TB and that the disk is of 2 TB so it is not going to enter, but accepting the warning in the end it is well.

I will save the image carefully if I have to use it again, although I hope not.

Since both Adam2311 and Bnnor recommend that I upgrade to the latest version, I will. It was what I was going to do, but how did they say there could be problems …

I have passed the complete tests of the disk and says that it is ok. Therefore I do not understand that it has been able to happen so that it slows that way and that there was no way to access even the web interface, nor copy or query anything of the connected network drives.

Thanks again for the help.

Greetings, Hector.