Folder.jpg not showing

I own the WDTV Live, and since I have owned it I cannot get the folder view to work.

For example I have an Action folder with a JPG image that is named folder.jpg

I have the latest firmware installed.

Are there any new tips to get the folder view to work?

Thanks

So what DO you see?  The default “folder” green icon?  Or something else?

Hi

Each folder shows an image from the first film in each folder.

For example, sci-fi folder shows Aliens for the folder image.

I have folder art for each folder but they refuse to display in my film folders.

The only one that works is my Home Movies folder, probably because the content of the folder is not a known film.

Try changing folder.jpg to folder.metathumb

I have a similar problem, i have 5 folders, and the folder.jpeg only shows in 1 of them, i dont know if its because theres no more images in the folder just 2 subfolders with mkv files and jpegs, but the 2 sub folders show the first film thumbnail in the list, the same with my other 4 folders, they each show the thumbnail of the first film…I havent found a fix yet

If there are any “metathumb” files in the folder, they will be used instead of “folder.jpg.”

Rename any metathumb files to the jpg extension:

filename.metathumb --> filename.jpg

I tried your tip and it still didn’t work :cry:

Thanks

Did you reboot to clear the cache?

here’s what worked for me.

folder.jpg —> 1.metathumb

works everytime on both my boxes.

Do you just rename the jpg to 1.metathumb or actually convert it to a metathumb file?

The .metathumb extension is not a true file, it is just a .jpg with the extension changed.

Just tried the 1.metathumb name and it worked ok, only problem is the quality was rubbish compared to the usual metathumbs lol

Another trick I have discovered using NAS storage and media library:
I have my video library organised thus:
/Family Movies
/Family Videos
/Adult Movies
Each folder has subfolders for instance:
/Family Movies
/Harry Potter
I was having trouble getting folder.jpg to show in /Harry Potter. Also each film was named in the order of release so:

  1. The Philosopher’s Stone.mp4. The idea being that once I had scraped the metadata they would appear in the correct order. Alas this was not the case and they were being listed in reverse order for some reason.

The fix:
I moved /Harry Potter to a location on the NAS outside of the media library.
Highlighted /Family Movies on the SMP, select options - rescan.
This rebuilt the library for the folder & rescans in a couple of minutes.
Then moved /Harry Potter back into /Family Movies and rescanned again.
Folder.jpg was now being correctly shown and all the movies were being displayed in the correct order.
Hope this helps.
Regards
Slip

Or you could have just opened the meta xml and change the title to

  1: Harry Potter and the Sorcerer’s Stone

  2: Harry Potter and the Chamber of Secrets

Then gone to the main folder and pressed Options/Rescan and then they would appear the the correct order, because that’s how the SMP sorts files, by the not the file name with the media library turned on.

The reason your’s is showing up in the correct order is because the media library did not get properly cleared.  And I bet that if you scoll through your files the file name appears just before the the does.

Does Options / Rescan also refresh changes to XML?   That’s new… :slight_smile:

I have managed to find a work around.

I uploaded my folder images to my rapidshare account, then I just saved them as 1.metathumb when I down loaded them again, which saved them as a metathumb file :smiley:

The only problem I have now is I corrupted my Action folder image.

Anyone know where I can download the pack again.

 This is the style of image

Those are mine and you can download them from here:

http://www.mediafire.com/?ap1cg993cbam9ib

1 Like

Thanks Tinwarble, your a star :smiley:

TonyPh12345 wrote:

Does Options / Rescan also refresh changes to XML?   That’s new… :slight_smile:

 

Some times, it seems to be hit or miss mostly miss, it seems to work better with my TG generated xmls.  The best way that I’ve found on an attached HDD is to eject it, then connect to my PC, delete the .wd_tv folder, clear the media library, then connect the HDD back into the SMP.  But even that can be problematic at times.  I have resorted to changing the drive name.:dizzy_face:

My only point to that though was that the cache wasn’t really cleared, that’s why it was showing in the correct order.  As soon as it does correctly clear, then they will go back to being out of order.

On a NAS, it’s like pulling teeth to get anything to change, especially if you use the internal scraper, which is why I don’t use it.

By the way here is a bat file that will convert all your .metathumbs to .jpg:  http://www.mediafire.com/?6tees164f3u3u96

Just copy it to every folder that has .metathumbs and then run it.  If your folders are on a NAS or on a attached HDD, make sure you map the drive and access it that way before you run it or it will not work.

Using .jpg rather than .metathumbs, as TonyPH12345 suggest, will keep you from having these issues and you can just use a regular “folder.jpg”.

I figured I’d put my 2 cents in on this conversation seems how I’ve received plenty of “how-to” knowledge from everyone here but this is how I got the Genre images to appear for the Genre folders. I’m sure there are plenty of methods that work differently for everyone but I found this to be the easiest & without changing any file extensions.
1.) I created all of the folders that I was going to use --> “Action” “Adventure” “Comedy” and so on…
2.) I put 1 movie in each folder…
3.) I put the Genre image that I wanted displayed as the Genre Folder image, which is a .jpg (all other movies where left in a folder by them selfs. I made sure that the “folder.jpg” (it was named Action.jpg-renamed it folder.jpg) was the first thing shown in the folder
—>MOVIES
Action ( folder )
folder.jpg ( genre image )
moviefile.mp4
4.) I left all of the Thumbgen generated files out.
5.) Once all of my folders where set, I made sure the wd_tv folder was deleted from everywhere, I went to the SMP made sure the “Get Content” was on Manual, then cleared the Media Library, restarted the SMP.
6.) Once I made sure the folders were displaying the proper image, I turned off the SMP, then cut & pasted all the movies (with the Thumbgen generated files) into the proper folder.

I’m sure that this was explained on how to do this, just figured I’d mention what worked for me. So hope it works for anyone else.