Folder disappeared after rename via web access

I renamed a folder in the public share. It was called Shared Photos and I changed it to Shared Photos and Videos… then the folder immediately disappeared and now I can’t find it.

I saw several other threads about this and other similar problems, but I didn’t really see any solutions…

It sounds like possibly there is some bug in the Web/App that causes a corruption of the file system. Some were able to find that their files were not actually deleted, but they were no longer tied to the location anymore.

I read one person was able to create a new folder with the same name as the missing folder, and the files appeared in the folder. I guess they were still associated with that folder name, although the folder was no longer there. In another case, the folders remained and the files disappeared - so perhaps the same thing in reverse, the folders were there, but the association with the folder(s) was lost.

I tried creating a folder with both the original name and the name I tried to change it to with no luck. I’m not as tech savvy as some - so I’ve never tried doing anything with SSH - though I’m not opposed to it if I can get my files back.

@psuttonjr

First, what device and operating system are you using to work with your My Cloud?

Did you change the original folder back to its original name, if yes, what happened?

I was using a windows 7 PC to access it remotely via the web client when it initially disappeared. I use a Macbook pro (usually) at home to access it locally. I’m using an Android phone to access it via the app otherwise.

I couldn’t change the original folder back to it’s original name, because after I changed the name it froze a second then it refreshed (on it’s own) and when it came up it wasn’t showing a folder at all.

I attempted to create a folder with both the original folder’s name and the new one, but both come up empty.

Now some interesting bits - the Android app has a search feature. If I search for folders, I can get some of them to show up… Here’s the hierarchy for this folder:

image

If I choose to view just photos in any folder under the main “Public” folder (a default share on the drive) a few random folders and images pops up - one of them is “Ember’s Photos” which is one that’s dissappeared.

If I search “Ember” or “Lila” it will find the folder, but if you try to select the folder, it will pop up an error like this:

If I search “100” (My daughter’s camera saves files with the format “100_0001.jpg”), I will find many of the photos, some of them (about 20) I can actually view and have successfully managed to save to my phone. The others show the generic no thumbnail image icon, and when I try to view it gives this error:

edit - I’ll post the screenshot in another reply, but it’s says “Invalid request. (404)”

I can’t seem to get any of the files under the “Goddard” folder to show up beyond the folders “Ember” and “Lila”. I suspect it’s due to each of those folders having child folders and files which were named the same (e.g. both likely had folders named “2018-03”, and files named 20180320(1).jpg, etc.). If they lost their parent folder and ended up in the same level I could see that causing problems.

Screenshot_20180327-080521

Just a bump on this to add:

While I’d love to get my data back (shame on me for not having it somewhere else) - It’s not the end of the world. I would however like to know what caused it since it seems to be easy to do and has affected others (I’m not just a fluke). It’s honestly put me off from considering the WD cloud products to be reliable as a backup/storage solution. I’m concerned now that this may have occurred while moving/archiving other folders and I may not even be aware of it.

For those of you whose drives are in good shape, back up your data now with other solutions. Inform your friends and colleagues who are still using that product.

You should be doing that for any NAS. Any HDD can fail, at any time. Therefore, you must have backups.

Would you like to stop spamming multiple threads, and perhaps post a thread outlining what problem you actually have, and maybe some members of this user community might be able to help you.

Well, I was really fed up when all the posts did not help. Now it’s all right.

So the OP and others don’t think they’re crazy, I’ll add that I experienced this very dangerous bug before too. Fortunately I was renaming a folder I already planned to delete shortly, but this definitely happened. I questioned myself at first, wondering if I had perhaps hit delete by mistake but there was never a confirmation dialog. I tried very slowly a second time renaming a test folder and sure enough, the folder was deleted instead, no confirmation dialog.

What do you mean by deleted? What was the original full patch name. What was the full new path name?

I mean deleted as in the folder and all its files suddenly cease to exist. It is as though the rename command in the webui actually issued an rm command on that entire directory and all subdirectories. Looking to either the old or the intended new path reveals nothing there. Logging into a shell and looking from there confirms.

Hummm
similar situation here
https://community.wd.com/t/folder-disappear-after-move-to-new-location/223613

Hi there, I am having the exact same issue. I renamed my photo directory from My Pictures to Archive and now it’s gone. When I search for some of the file names they aren’t coming up either. Has anyone been able to find a way to resolve this? I really want to recover all my saved photos! Thanks

If you have local network access to the My Cloud, check the Share (or the subfolder) with Windows File Explorer or Mac Finder to see if the renamed directory is there.

One could try disabling Remote Access, wait a few minutes then reenable it in the My Cloud Dashboard > Settings to see if that also fixes the issue.

Or one may have to access the My Cloud Dashboard > Settings > General > Cloud Access > Remote access, then click on the Configure link. A dialog window will appear where you can select the Content Database Rebuild button.