[FIX] [WD] Internal hard disk not found - Solution

Hey guys, after buying a media center from WD a couple of days ago, it ‘died’ on me today after putting some tv shows on it.

So, as every other human, I started to look for a fix on our dear WWW.

Naturally, there were lots of  ‘fixes’ and ‘solutions’, most of the questions were answered just by saying to return the device.

Now, let me just put some info on this.

  • When booted, the device would stay a while on the logo then show the internal disk error

  • When connected to a PC, the drive wouldn’t be shown on My Computer/Total Commander

  • In Disk Management the device would be shown just as a disk, but you couldn’t right click on it or do anything with it

  • The actual disk wouldn’t have an assigned letter

And let’s get to the fix.

So, what you need is some disk management software other than the windows default. I myself used  Acronis Disk Director (which I’d recommend as that’s the one I’ll be using to explain the fix), so either buy it, use a trial or find it by some other means (… “yarr” if you get my drift).

Install the software and start it up.

On the start screen you’d see Disk 1/Disk 2/Disk 3, etc. If you’ve only got 1/2 internal disks it shouldn’t be a problem locating the WD disk of the device.

So, when you’ve found the disk, do the following:

  1. Right click on it and press [Change letter]

  2. Assign any letter to the disk, press ok and you will see a bar pop-up above in an orange-ish color

  3. Press the bar (“Commit pending Operations”) and continue

  4. After the letter has been assigned, right click on the disk again and press [Change partition type]

     - By default it should be on '027h - PQservice, Windows RE hidden

  1. Change the partition type to '07h - Windows NTFS, Windows exFAT, OS/2 HPFS

  2. Press ok and the above mentioned bar should pop up again, press on it again and continue

And that’s that. Device fixed and in working state.

If you’ve got any questions, shoot. 


Now this is helpful, kudos!

Spot on Smeagoul!!

Saved me heaps of time.


Thanks to you You have saved me by the process

HI there,

I was so relieved to see you fix but for 2 days been struggling and not getting anywhere so please help!  I have downloaded the Acronis Disc Director trial version and I can see my  disk however it says the drive is Uninitialized and when I right click it attempts to  change the status to online which runs for abouy 2 hours with no movement.  I am missing my media player, do you have any other suggestions to fix this?  I have thought of throwing it out the window as its been almost 2 weeks and still not feedback from WD support to my query!!!

I am holding my breath and hopting you can come up with a solution.



YAY - Thank you Western Digital for my replacement media player and for the speedy response!!  I am one happy client :slight_smile:

i have an internal WD 500GB hard. 

at first the hard stopped detecting i think it happened after a power failure. then after a cleaning the PC it detected and open once. it show an error saying windows system 32 file is corrupted check disk it and got stuck. after the second boot it never opened and i had to use a live run windows CD to check the Hard. after the windows open the hard shows C drive as corrupted says to format and D drive was perfect. yes thats the same Hard with two partition. when i start chkdsk it started showing unreachable. and later on after some boots the hard stopped showing on the PC and even cant run live CD while the hard is connected. any fix for this anyone??

what if the device is not detected. not found in the my computer but the device is connected and i can hear the sound of the disk working. will it still be fixed

Yes, wonderful guide, but my hard disc isn’t detected also by Acronis :frowning:

any other help?

Hi I bought a WD terabyte external HDD (p/n WDBABV0020BBK-00) and it was brilliant for about a month with my Mac but having left it in the drawer for a few weeks it has decided not to exist - i.e. it first of all said it was corrupted then when I plugged it in it is not discoverable. I plugged it in to my PC and it showed so I tried to re-format it accepting that the data I had backed up was lost, but then that stopped working and it is undiscoverable on the PC

I tired downloading the Acronis Disk Director but this can’t see it either.

Help! It was such a fantastic piece of kit, and now it [Deleted]. Such a shame!!

Any ideas?