[Fix] MyNet N900 2TB central remote access "unknown error"

just found out that if you set your router password (not the wifi password) starting with special characters ( !%#@[(*]) the remote access will break.

for quick fix just change your router’s password to a simpler password (i know). -_-


* it seem like it keeps any setting you made in the remote access tab when you change the password with a special character even though it breaks it right after you reboot.

*so  if you want to keep a secure password with remote access, change settings in your remote access tab first then change your router’s password.

*if you want to add a device to remote access, just change the password to a simpler pass then change it back to your secure password after adding the device.


*this worked for my WD n900 central 2tb

just wanted to share what i found out for people who are experiencing this problem and  hopefully someone at WD will fix this at the next firmware update!

Yup, I think that special characters are not supported for the password.