FIX for mac sharing for you!


#1

Will share this so far unknown ‘bug’ or weird behaviour that might fix your mac sharing.

you’ve tried everything so far:

  • set it up WIRED, to eliminate possible wifi-issues

  • checked FILE SHARING in prefs->sharing, AND SMB-sharing under OPTIONS

  • under prefs->network->advanced->WINS you’ve made sure that your workgroup name matches the one from the WDHUB. By default this is “WORKGROUP” on the HUB, it should be “workgroup” on your mac, (not capitals). 

-> activated guest account, allowing sharing.

  • you’ve made sure that in the prefs->sharing window named “USERS” all permissions are set to READ AND WRITE.

STILL NOT WORKING?? You’re probably going nuts right now, just like I was :slight_smile:

Fear not: Well, as it turns out, the WD-HUB will ONLY see folders or users that have permissions given to a group named “STAFF” and set to Read & Write. Now, normally this would not be and issue since by default home-folder and public folder of any user-account has this group. BUT; if this has somehow been removed (by mistake, or for security reasons) there is NO WAY to get it back. YOU CANNOT SIMPLY ADD THIS GROUP!!!

This was the reason my network never showed up on the HUB.

Easy Fix? Create a NEW USER ACCOUNT. Call it whatever you want. Add it to the SHARED FOLDERS, and set the STAFF PERMISSIONS to read/write…

Good luck! 

AND REMEMBER; every time you change ANY SETTING on your network, you MUST restart your WD-HUB, I did it by going to setup -> system -> device restart.

zballZ!


#2

zballz wrote:

Will share this so far unknown ‘bug’ or weird behaviour that might fix your mac sharing.

 

you’ve tried everything so far:

 

  • set it up WIRED, to eliminate possible wifi-issues
  • checked FILE SHARING in prefs->sharing, AND SMB-sharing under OPTIONS
  • under prefs->network->advanced->WINS you’ve made sure that your workgroup name matches the one from the WDHUB. By default this is “WORKGROUP” on the HUB, it should be “workgroup” on your mac, (not capitals). 

-> activated guest account, allowing sharing.

  • you’ve made sure that in the prefs->sharing window named “USERS” all permissions are set to READ AND WRITE.

 

STILL NOT WORKING?? You’re probably going nuts right now, just like I was :slight_smile:

 

Fear not: Well, as it turns out, the WD-HUB will ONLY see folders or users that have permissions given to a group named “STAFF” and set to Read & Write. Now, normally this would not be and issue since by default home-folder and public folder of any user-account has this group. BUT; if this has somehow been removed (by mistake, or for security reasons) there is NO WAY to get it back. YOU CANNOT SIMPLY ADD THIS GROUP!!!

 

This was the reason my network never showed up on the HUB.

 

Easy Fix? Create a NEW USER ACCOUNT. Call it whatever you want. Add it to the SHARED FOLDERS, and set the STAFF PERMISSIONS to read/write…

 

Good luck! 

 

AND REMEMBER; every time you change ANY SETTING on your network, you MUST restart your WD-HUB, I did it by going to setup -> system -> device restart.

 

zballZ!

 

If it wouldn’t be too much trouble could you walk me thru it in detail.  In my system prefs under network I don’t see anything called SMBs or Advanced> WINS.   I’m running OS X 10.4.11… if that helps.  And my machine cannot upgrade any further… or I would. 

Cheers.

-B


#3

I would be happy to, but not possible for me. I’m running snow leopard, and have no way to troubleshoot on tiger.

SMB should be somewhere in your “sharing”-tabs, or something similar that enables “windows sharing”…


#4

Thanks for pointing me in the right direction however I still can’t get my WD TV Live hub to let me file share with my Mac. I am running the latest OS and have been hung out to dry by WD’s phone support. Any help would be greatly appreciated. I just want to drag and drop my movies I’m converting over to MKV into this live hub. On a side note what is the best format for movies that give me the best pic quality and the least space? I’ve been using MKV. 


#5

OS X 10.4 doesn’t do SMB sharing. You’ll need to install the SharePoints Preference Pane (it’s shareware), and educate yourself about windows networking and networking in general. It’s not something that can be converted to an easy walk-through in forum postings. I didn’t know anything myself, but I did get it to work.

I needed to do that when I was using a Neuros OSD. I’d upgraded to Snow Leopard before I bought my TV LIve.