Firmware Update Module Failed to Start?

Hi everyone,

    Im running windows 7 64 bit.  I’m trying to update my passport essential drives but the firmware update is not working.  I have downloaded the universal one.  I followed the instructions and once I hit “update” after its done downloading whatever it needs to download it says that " A WD Firmware update module failed to start."  What is going on?  My system is reading the drives just fine.  I did the smartware update just fine.  My antivirus/antispyware is off.  Anyone else have this problem?


What firmware version do you have on your passport?

Also, you did follow all and every one of the instructions correct?  You didn’t leave any other drive connected, or spyware software running, did you.  And please make sure that you have your data backed up before trying it again. 

I have the exactly same problem than Frost271.

What I have:
My Passport Essencial SE 2.0/3.0 USB 1TB Silver (WDBACX0010BSL-00) with 1.014 firmware

Intel Core 2 Duo Asus P5WDH Deluxe board

Windows 7 Ultimate SP1

When I try to update its firmware from 1.014 to 1.016 I get the same error: “A WD Firmware update module failed to start”. That’s it. Of course, I’ve tried to disconnect and turn off everything I could find, from antivirus/spyware programs, to webcam. It’s useless.

One more curious thing. I’ve tried to update its firmware with a Mac (Snow Leopard) — the updater recognizes the drive as 0730. It goes fine and do… NOTHING. The update proccess finishes beautifully, but WD SmartWare (on Mac and Windows) keeps showing the old 1.014 firmware.

I upadated its firmaware months ago from its original one to 1.014 and it worked fine. The drive is working fine too, on Mac and Windows.

Does anyone have any clue? I’d appreciate, thanks.

Can you completely delete the firmware updater from your computer, ensure that your firewall is turned off, then try downloading the update once more?

Please let me know what happens.

Exactly the same problem here at 2 hard disks. firewall an Norton Antivirus is off.