Firmware Update Issue 6.00.5200.11

Hi, having issues updating the firmware on my G-Speed Shuttle Thunderbolt 3. Currently I’m on firmware version 6.00.5200.10 and a popup keeps appearing when I go on the app to update to 6.00.5200.11 and every time I do it does its thing and restarts and still doesn’t update the firmware.

I’ve tried manually downloading and installing the update but no luck. Software is up to date on my mac which is running MacOS Mojave, please advise.

Tried reporting it on the Helpdesk but the webpage keeps throwing up an unexpected error.


Can anyone help??? not even got a reply from WD staff what kind of poor customer service is this!

Uninstall your software fully and download and reinstall from our site here: G-Speed Software Utility

I am also having this issue. I have uninstalled an re-installed the software utility a few times but to no avail.

For anyone encountering a similar issue.
I just followed up with support on the phone. They said that unless there are issues other than updating firmware, not to worry about the update until you encounter a problem.
In other words, if ain’t broke, don’t fix it.

I’ve having the exact same issue. I just purchased this G-Speed Shuttle XL with TB3 this week and it has firmware 6.00.5200.04 installed and I’m getting prompted to install 6.00.5200.11. I’ve tried to update it twice but each time it just reboots with the old firmware on it. I’d rather not have this thing start off life with old firmware–particularly since the update is “recommended for all users.” Is there any way to update this thing?

For whatever reason, I managed to update my firmware, this morning. It might have been the latest Mac OS update I performed recently that allowed for the firmware flash to take place?
No idea.
Perhaps those who were also struggling before can try again.