Firmware update Catch-22 (can't install because "drive in use")

I just downloaded the latest firmware update. When I try to run it, I get as far as it asking me for the password. That works. Then when I continue the update, it says that the drive is in use and I should close any program accessing the drive. At first, I thought it my be a problem with autoplay starting up. I disabled that. Now I can’t see any other program accessing my drive other than the WD software itself. So what could be blocking the update? Running Windows 7 Ultimate on a Panasonic Toughbook CF-W8 with admin logon. Plugged in to AC and ethernet to my router. Disable Norton Internet Security’s anti-virus autoprotect.

If you are using the drive without any issues I wouldn’t bother with the firmware update. If it ain’t broke don’t fix it.You only need to do it if you are havng problems.


I am having a problem, but I don’t know if the firmware upgrade would help. In a way, it is similar to the problem as my OP. I have never been able to disconnect my Passport drive. Before the lastest software upgrade, I never even saw WD Quick View with its option to “Safely remove”. Now I have it but it doesn’t work for me. It says: “The device cannot be removed. Close all running programs.” That’s kind of rediculous, since there are dozens of processes and services running all the time that cannot be closed. Everything I can manually close I have, other than the Norton programs.

I get that drive cannot be removed when I run a Sync program. If I log off then log back on it removes OK then. If I copy files manually the drive removes OK. There are a lot of things it colud be. AV and other security software or automatic backup software or a combination of them. I gave up trying to figure out why. Have you tried stopping the WD processes in the Task Manager when trying to remove the drive?


I just log on, unlock the drive, and close the drive unlock window. That leaves quick view running, which is where I try to “safely remove.” I haven’t even tried to do anything with the WD drive at that point. I did just try something else. I logged on as an administrator. At least on one try, as long as I first closed the drive unlock window, I could do the “safely remove” in Quick View. So maybe this has something to to with rights. It shouldn’t, of course. Also, when logged on as a user, there’s no message asking for elevation or admin rights so I can’t be sure. It really is a risk situation if there’s no way to lock the drive save pulling the plug. Either the drive is always unlocked or some open file may be damaged by pulling the plug without closing the drive. With care, that probably won’t happen. But still, it really is annoying to have to reboot just to disconnect the drive.

Ok, now I am convinced it is a rights problem. If I log on with admin rights, “safely disconnect” in WD Quick View works as it should. If I log on as a regular user, I am prompted for an admin password just to run the Unlock program. This suggests that admin rights might also be needed to lock (= safely remove). This could be because the re-lock program is different from the unlock program. Otherwise, the unlock program would already be running with admin rights and could re-lock.

I cannot see any way to run the re-lock program with admin rights once I’ve first logged on as a user. Even if I then Switch Users to an admin user, I can’t “safely remove.” I have to Restart.

The WD software engineers need to look at this. It is not a Microsoft Windows problem, or at least need not be. I use a hardware encrypted USB stick that has the unlock program onboard just like the Passport. That program loads as a virtual CDROM drive, just like WD. I don’t need admin rights to unlock or lock it and remove the USB stick. If those folks can figure out how to run without admin rights, WD should be able to.

Thanks for posting back. The sharing/permission ownership thing has got to be a major pain since Vista came out I had problems after SP1 for Windows 7 and had to redo one of the drives settings to access it.


Well, in the end I did the firmware update. I was able to do it by logging on as an admin, proving my point that it is a problem of rights. So I solved my OP myself, albeit almost accidentally. I didn’t solve the followup question, which was how to re-lock or safely remove the drive when logged on as a regular user. That will need someone from WD to fix.