Firmware Release 4.00.01-623 not working for remote access

I updated Mycloud to the latest Firmware Release 4.00.01-623 and now I cannot access Mycloud remotely via the app on android or with a remote computer. I am getting and error (Network Connection Failure 905). The previous firmware worked great, never stopped working and I was able to access everything from anywhere. I did not change any settings on the dashboard or the router. I am seriously considering rolling back to the previous version. Any suggestions??

1 Like

that FW is better in most areas, I would not roll back

in the android app did you delete the device and try again? go into the app manager and clear the cache for it and the data.

how are you connecting from the remote computer?

are you on static IP or DHCP, I suggest static.

port forwarding? if so try turning this off and using upnp in the router

check the cloud access screen for errors or settings

any errors being displayed?

glad you posted this, as I’ve start to think that my newly bought MyCloud isn’t working propery, guess I shouldn’t start work with device from upgrading it to latest firmware as it bring some nasty bugs as appears. One of them is that I couldn’t use remote connection. In wd2go I see that my device is offline, no matter what I’m trying to do and what ports to open.


it seems that I’m able to access NAS remotely now, to do this I first remove device from wd2go and later creating assoication from beginning. At least now I’m able to access MyCloud remotely through machine running Windows, didn’t tried Android yet.