Firmware download fails

I am trying to update the firmware of my Passport Essentials

I downloaded and extracted the zip file

I run the file and when it tries to download the module I get the following message:

WD Firmware Updater download failed. Check your internet connection; then run the WD Firmware Updater again

I first tried it from my work network but when that didnt work I connected via 3G and it still fails

Any suggestions?

If the drive is working don’t bother with the updates I don’t. If it ain’t broke don’t fix it.


Any reason why you need to update?

If the drive is working fine then skip that… " If it aint broke… don’t fix it "

if you still want to update the firmware, follow the steps on the link bellow

make sure to follow all of the steps so you don’t endup with a dead drive


Lol JoelS posted almost simultaneously

Thanks. I was advised to update as my drive isn’t working with USB3 ports

Make sure your USB 3.0 drivers are up to date. If this is an addon card check the manufacturer’s site for updates. USB 3.0 can be a bit buggy.