Firmware 3.05.10 Too Slow?


I have updated to this revision and I am facing the following issue :

When the power is down after turning it on, it takes around 20 to 30 seconds to send any signal to my TV.

During this mean time the front panel  WD light is ON (however the configuration is off by setup),

Also, the internal Hard Disk is off and internal fan is off.

After this time, the WD shows LOADING on my TV, then WD light turns off .

That Loading phase takes more 30 seconds to be ready.

So, now in total it takes around 1 minute for complete start up.

That behavior didn’t exist in the original revision 2.04.13 when I bought the WD player. Before was very fast during this start up. Around 10 seconds it was ready to use.

Also, when everything is up, then I press the Turn off button on remote control, the player freezes for 5 seconds before OFF.

Can anybody  tell me if this behavior is correct with this newest revision ?

The most strange for me is the first 30 seconds when nothing is done before start loading.



obs. : The hard reset (the button below of the hardware) has been tried. But the result is the same. Too slow start up.

Mines not that slow, and I’m running latest firmware. If i’ve just put it into standby, then turn it back on, and hit HDMI on my tv’s remote control, i’d say it takes no more than 10 seconds to have picture and be working.  Only had mine a week though, so maybe a slightly newer build?

Or are you turning it completely off? And powering it down totally? It’s not meant to operate like that every time you turn it on, so does self checks and reindexes all the media library, could that be why yours takes longer?


Yes, I am considering turning it completely off and complete start up.

But the strang thing is about the time before start Loading. During this period nothing is done. Insternal Hard Disk and internal fan is off as well.  Only the WD front panel light is on for about 30 seconds. On TV no signal is received during this mean time.

After that time WD light turns off, HArd Disk and fan turns on and Loading software procedure starts. On TV it shows LOADING. After more 30 seconds for loading the interface is ready. Now I see the message checking library and so on that you are talking about.

Also I only have 1 movie stored in my Hard Disk, not so many things to index in the library. The Hard Disk in fact is completely empty.

The previous and original firmware revision was ok. This problem appeared after upgrade to 3.05.10

Thanks for reply,


Try reflashing it again maybe, something could have gone wrong with the update I suppose.  I timed mine earlier, from tv on with blackscreen, to all working took about 8 seconds.

Thats from standby, not powered down.  I never completely power down, the box is’nt meant to be.  Also keep in mind if you hold the power button for more than 3 seconds while powering down it does a complete reset not a standby.

Just tried it with the alaska theme which is the lightweight one i normally use. 3 second from black screen to fully working.

Narny wrote:


 I never completely power down, the box is’nt meant to be.  

Really, who said that?

Well when you completely power it down and then turn it back in it reindexes and purges all the cache. If he’s doing that no wonder its slow every time he turns it on again.  I just put mine to sleep with one click of the power button, that way when it turns on , no complete rebuild, takes a couple of seconds.  If you put more files on it auto updates those individually anyway. So why would you want to keep turning the power off?

Mine seems considerably slower since the upgrade to 3.05.10.  Once it’s up and running it’s fine.  But it takes a good minute or two to boot up completely.  

I’ve also noticed it’s slow when accessing from my computer.  I’ll open the network share folder and it’ll hang for a solid minute or two before I can actually access files/folders.  This might be unrelated though . . .