Firmware 2.02.32 | How to use P2P downloads with tablet?

I tried using the P2P download through Chrome on the Nexus 10, but the “Add torrent” & “Upload” buttons don’t work.

I also tried using the remote app, but it doesn’t give me the option to add torrents.

It works normally when I use it via the laptop, though. Below are details for the tablet, if needed.

Tablet: Nexus 10

Android version: 4.4.4

Kernel version: 3.4.39-gd52af31

Build number: KTU84P

WD TV Remote: version 2.0.0


Can you please provide more information about your case?

What are you trying to accomplish?

What is the model number of the unit that you have?

The model no. is WDBGXT0000NBK-01

What I’m trying to do is use the WD TV Downloads app, to download a torrent to an external HD.
When I try to do this via the Nexus 10’s Chrome browser, I can’t add a torrent from File or URL, because the buttons aren’t responding.
I also tried the remote app (in case I was doing it wrong) but it doesn’t have an option for adding torrents.

With the tablet, I usually use the remote app instead of the browser page.

This is the 2nd torrent download I’m trying out, so P2P is still enabled & everything else works properly (the last torrent was added from my laptop). So I’m wondering if I’m still doing it wrong or if it just doesn’t work with the tablet.