Firmware 1.13.18 update broke everything which was working for me!

Yesterday my WD TV Live showed that a new firmware was available. I was excited to expect lots of bug fixes and probably a few new features such as 32x forward etc. As such I clicked on the on screen TV menu to download and install the new firmware.

With this, all mayhem broke loose. I use my device to play mp4 and flv files for my kid.

Everything was working perfectly before the firmware update. After the firmware update, the device has become extremely unstable. 90% of my videos have stopped playing. Some videos start, but sound does not play. Some videos start playing, but get stuck after about 2 seconds or so. On some videos(which were all playing before update) now WD TV live is giving error “Unsupported file format, please see documentation to see which formats are supported” and on playing some the device says “a fatal error has occurred, and the device will need to restart”.

I have tried the factory default reset option from the WD TV Live menu. I have tried the hardware reset button on the bottom, after which I have also tried switching off the power mains, and disconnecting the power. I have tried removing my USB drive and scanning it in Windows for error.

Please help me get my device working again :frowning:

I am now trying to rollback to a previous version. I downloaded 1.12.14 and put it in the root of a usb pen drive. I then inserted the drive on WD TV, but its not giving me any notificaiton to install the firmware.

How do I rollback the firmware?

Thanks Tony, but that is what I was following. As I mentioned, on inserting the USB drive, no option came asking me to install the firmware.

the same happened to me today. At first excited  = expecting fixes for a number of format problems in video formats. FLV format playing would be great. Now with the new 1.13.18 about 90% of all content in my media store will not play, neither from usb harddisk nor media server. Practically all mp4 will not display even though it is the most popular format today.   :-((((

There seem to be some new functions in the network access. But - if I find more content, it is useless if it does not display.

What an improvement !

Any help to get my device back up would be apreciated. I am more desperate becuase my 7 month old child eats food only while vewiing a few specific videos, which I used to play via WD Live… Now, it s big problem with no way to play the video on TV due to this WD update. Not good WD :frowning:

waveking wrote:

Thanks Tony, but that is what I was following. As I mentioned, on inserting the USB drive, no option came asking me to install the firmware.

…and you downloaded the firmware from THAT PAGE?

THAT was the catch. I didnt know WD needs to hack the firmware version for the device to be able to read it.

That page did not have 1.12.14 so I had downloaded the same from an alternate location. Anyway, I downloaded the 1.11.14 from this page and was able to flash it, and make my videos work again *phew*. Thanks.

So In the end, thanks to the WD update, I had to go 2 versions back and loose the features which even my current version had. Didn’t expect this from WD.

Well now that you have rolled back you can update to 1.12.14. You already have the firmware so put it on a USB drive and update. Sorted and back where you were.

I have the same problem I have two players updated on and some files will not play on it (they play on my other box) I hope WD gets it fixed ASAP. Anyone have a step by step guide on how to roll back the firmware. 

Dont hold your breath they have had audio issues with netflix and hulu for 6 months and they have yet to figure out the problem…even after 2 new software releases

save yourself the headache scrap it now and go buy the roku

its more money but it DOES workk flawlessly

Flawlessly? That’s not true for ANY player out there.

sactosjm - Do try and help yourself and read the thread. The rollback instruction link is only a few posts above your post.

ya I know I was HOPING the folks at WD would fix this for my i JUST bought one for my uncle and he just updated it and now he has the same problem. I guess after i figure mine out i get to drive over to his place and fix his… THANKS WD…

I wonder by when will WD release a fixed firmware which works out of the box fixing this glaring issue of breaking video formats

Probably not before it’s able to reproduce them which doesn’t seem too likely since many people including me don’t have any problems with their (old) files. Upload some clips of your files that suddenly don’t work to Mediafire so we can give them a try.

I did a factory default and then updated my box and what happened!

Nothing it worked as advertised with out all the issues reported.

Why are people so shocked when they put software over software and not expect code and setting issues?

You wouldn’t do this in nearly any other electronic environment but most seem so shocked when things hit the fan because of it.

As mentioned no box is flawless but many of the problems are do other issues like this rather then the box themselves.


<Why are people so shocked when they put software over software and not expect code and setting issues?


You wouldn’t do this in nearly any other electronic environment but most seem so shocked when things hit the fan because of it.>


UH really? I I don’t factory reset my PC or my Android everytime I update the firmware. My Android and PC don’t crash when I update them… My TV didn’t crash when the firmware updated. I updated to the 1.13 a few nights ago after finally getting it to work again (it was crashing and hanging) and everything was working.  Tonight my wife goes to play a file we have played before many times and it hangs and I have to unplug it. I plug it in and I get the WD logo then it flashes and I don’t get the 2nd one. It just keeps cycling. I unplug everything, network, hdmi, usb drives and still nothing. This thing is junk!!

Ever tech show and ever expert well tell you the same thing.

Do a update clean and not over old code its a bad idea at the best of times.

Android devices and TV update differently then many devices  to prevent possible bricking of the device by using a separate partition for the firmware and data.

More devices should do this but cost often prevents this or the making just cuts corners.

Instead of arguing the point why don’t you actually do as suggested and see how it works.

People keep blaming hardware without ever doing as recommend.

I been doing this for over thirty years and its the same thing over and over.Its a piece of junk it doesn’t work.Did you do as recommended?

No but its still the devices fault it should update fine… Notice how foolish that sounds.

The simple truth of the matter is putting new code over old code has never worked well and doing something fresh is always the best.

Its only going you ten min to do so and very likely  make you happy or you can spend more time arguing .

Its up to you but you shall be arguing by yourself.

To answer your question, yes I did a factory reset with the button on the underside and then updated the firmware to latest and it didn’t fix anything. That is basic troubleshooting. I’ve did all of this before calling support.

I’ve done everything they recommended. They even sent me a WD TV Live Hub. It won’t see both of my drives. I have a 3TB and a 2TB. They had me hook my drives up to my computer and delete the “wd” folder that is created by the player. Guess what? I did that after I removed the drives from the SMP before connecting them to the hub to ensure that I didn’t transfer settings or a config file that might cause an issue on the new player. I hooked up the drives and the hub will see the internal drive and the 3TB but not the 2TB regardless of USB port…

So back to the SMP device. I have included links of the two issues.

The first link is of me moving a file between folders on the same harddrive that is attached to the WD TV Live SMP.

The second link is of the unit stuck in a boot loop. I unplugged the device and plugged it back in to see if this would correct the first issue.

Since this I have unplugged the unit and I am going see if it will boot.

The only thing I can think of is that there is leaky code because I cannot reproduce the issue by doing any one thing. This issues happen at random. The 3rd issue I have I did not video at this time but when it happens I will be recording that and adding it to my list.