Finally fixed dashboard

Im not saying this method is right for everyone and could be curing the disease by killing the patient but its the only thing that has worked for me after trying every other thing I could find on here.

Ages ago I bricked my Mycloud and had to rebuild my partitions and dd the
seperate images files to each partition this put it on version 2.30 I
think which all worked ok. The problem came when I then tried to upgrade
the firmware to the latest version no matter what I did I could only
get the dashboard for the first few minutes and even then with loads of
error messages. I was pulling my hair out until I figured out why. The
method described for rebuilding the partitions on this forum (the one
thats on the google docs in russian) seems to have or introduce errors
not sure where it might be the images or the partition build in anycase
it won’t upgrade correctly and you have more and more issues as time
goes on. I am not saying that the great work from that user is invalid but just describing my situation.

My Fix

Remove drive and connect it to computer via USB or esata.

Download and install parted magic to a usb stick and boot to it. Search for pmagic_2013_08_01.iso
This is much better than gparted as if has wifi and so many other useful items.

Backup your data from the ext4 partition.
Unmount md127 if it is showing in the gui partition program. Had to do this via the command line.

Remove all partitions
I also removed the superblocks though not sure I needed to?
Format drive to no file system (the black one) this should only take a few seconds again do this from the gui but make sure your formating the correct drive in my case it was sdb.

Download the full disk image and extract the image (seach google for mycloud2tb_transmission_v03.04.01-230). Open the terminal at that location and then dd it to your my cloud.

dd if=/mnt/hd3/WDC/mycloud2tb_transmission_v03.04.01-230.img of=/dev/sdb (sdb is my mycloud drive but confirm this before you do it or you might overwrite your computers HD) takes about 30 mins.
This was a prehacked image that included transmission but dont worry when you get to update the firmware it will return it to the stock version.

Rebuild drive and boot
Do system only restore via the mycloud ui.

Then upgrade your drive to latest FW. I did it via the Mycloud app not my PC but not sure that made any difference.

Give it time to complete than dashboard
will work and you will be on latest firmware.

Basicly all you need to do is format the disk to no file system and remove any superblocks.
dd the image from terminal
rebuild and boot
system only restore
then update.

All is not working for me by using this method but I cant tell you the exact reason why.

Good luck

1 Like

Hello there,

Thanks for sharing this with the community, hopefully this helps other users with the similar issue that might be willing to try this.