Files won't write to My Passport

Hi, I have a problem with My Passport for Mac. Any time I try to add any file(s) to My Passport, the transfer eventually fails with a message reading “The finder can’t complete the operation because some date in “[insert file/folder name]” can’t be read or written.   (Error code =-36)”

I can access files saved on My Passport, but not add any files. If I try to import a folder that is already on My Passport, the failed transfer will overwrite any files I already saved on My Passport. I have tried repairing the disk through Disc Utility, but that has not helped me.

I am unaware of anything I could have done to create this problem. (As far as I can tell, the problem started on its own.) Does anyone have any suggestions: Does partioning the disc actually help? Should I take it directly to Western Digital (I should have some time on my warranty left).

What OS are you using and has this drive been used on more than one OS? How is the drive formatted?


I’m still on Snow Leopard (10.6.8). I’ve had the drive since I had Leopard running on my computer.

1 Like

Huge problems for me.

I’m a new Western Digital customer, and boy, do I regret it.

My drive, out of the box, is formatted NTFS.

I don’t need the drive to be accessible by both Mac and PC, but I CERTAINLY expect to be able to read & write to it. 

This forum tells me that a standard hard drive reformat will KILL my drive:

and when I try running WD Quick Drive Format, I get this error:

CANNOT DISMOUNT VOLUMES   One of the volumes on the device is busy and cannot be dismounted.

I’ve never experienced any kind of problem with drives from other manufacturers.

What’s going on with this product?

Well for a start you bought a drive formatted for Windows NTFS not for a Mac. I don’t know much about Macs maybe you missed something when you tried to reformat. See if this helps