Just got a My Book live and use it with my wireless netradio. I have some mp3’s that i can play on the wireless player, and the files are in my shared folder (shared music). My problem is, that mybook ignore the file names in the folder, e.g.: 01, 02, 03 and are listing them alphabetically, so the music is playing in the wrong order. Is there a way to prevent that? 

Hmm.   Is your player accessing the MBL via its Twonky server, or via some network sharing protocol like Samba?

My media players are sorting them by Track order, not alphabetically, through Twonky…

And all my file names begin with the track number…

Even DLNA does the same thing in playing files alphabetically, IF via genre, artist, album; at least with the Netgear router’s version used with a drive attached to the usb port.

However, as with twonky, if I selected “folders” then downwards to the album, the files are played in the track order.

The whole thing could be on how one enters the albums, but don’t think so.  When I select the artist category, sometimes the album(s) show up but more likely alll songs that the artist has shows up but NOT in album order.

I truly think that the whomever did the specs/implementations messed up & think that the most important item was the song/composition & disregard that people do use album as a selection for playing music.  It does make things VERY MESSY when trying to play classical music much less jazz/pops where song dups/versions abound.

Sure is irritating when playing a live concert!!

I dont know how it works or plays via a server, but i think it does, cause there is album covers and stuff in the folders, which i haven’t put there…

can i somehow avoid the server, and just access the booklive as a simple harddrive? If i go to the album folder, the songs are in correct order, but i like to use the folder option.

thank you for helping!!