File System Errors with 2TB Caviar Black


#1

I just made some upgrades to my pc, I had an HP Pavilion a6157c with Windows Vista Home Premium 32 bit. I upgraded the processor first (from a Core 2 Duo E4400 @ 2.0 Ghz to a Core 2 Duo E8500 @ 3.16 Ghz, that way I could upgrade to a 64bit Windows 7 ) and everything worked great, then I proceeded to install Windows 7 Home Premium 64 bit and again, everything worked great, the I installed the drivers from the motherboard (Asus P5Q Pro Turbo) and when I restarted my PC after the installation the nightmare began…

It took my PC around 1 hour to boot, it stayed a LONG time showing me the flash screen, so I restored the PC to the previous point to the drivers installation and everything worked great. I didn’t try to install the drivers again, seems like they’re not needed. Then I replaced the RAM (Corsair XMS2 4GB).

I started to install games put my multimedia files into my secondary hard drive (2TB Western Digital Caviar Black), that I bought 1 month ago (no issues until now). The application and games that I installed on the drive stopped working, when I tried to access some folders where “corrupted and unreadable” according to Windows. So in Computer under the driver properties>tools>error checking>check now, I checked the two boxes “Automatically fix file system errors” and “Scan for and attempt recovery of bad sectors” and then “Start”. It took like 6 hours or more but then it got fixed.

But now the file system is getting corrupted again and again, I have to reinstall programs in order to get them to work, I’m trying to not use the drive but I have too many files and my main HD is not enough for them, and now some files are getting corrupted, their size gets reduced to 0 bytes. And to access some folders I have to fix the file system under error checking (not the bad sectors), I’ve done this like 10 times during  last weekend.

Please, do you have any suggestions?


#2

Have you checked to make sure that your power and data cables are correctly seated?


#3

I did, but no problem there, it worked perfectly under Vista. The problem began after installing 7 and (probably) replacing the RAM, but I was told in another forum to run MemTest86+ because bad memory could corrupt data, could that be the problem?


#4

Absolutely.  Also, make sure your RAM is correctly seated, as well.  Definitely run the Memtest.  If there are any issues replace the ram.